summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode (prometheanfire) <mthode@mthode.org>2010-07-15 00:02:51 +0000
committerMatthew Thode (prometheanfire) <mthode@mthode.org>2010-07-15 00:02:51 +0000
commit5e7f13022a86cc4eed6564883fd7dc051cc88d24 (patch)
tree5cbe17a064d0dc132ce87b0c8a34b2497da7003d /net-analyzer/icinga
parentapp-accessibility/onboard: Version bump. (diff)
downloadsunrise-5e7f13022a86cc4eed6564883fd7dc051cc88d24.tar.gz
sunrise-5e7f13022a86cc4eed6564883fd7dc051cc88d24.tar.bz2
sunrise-5e7f13022a86cc4eed6564883fd7dc051cc88d24.zip
net-analyzer/icinga: New Ebuild for bug 271339 thanks to chithead
svn path=/sunrise/; revision=11016
Diffstat (limited to 'net-analyzer/icinga')
-rw-r--r--net-analyzer/icinga/ChangeLog8
-rw-r--r--net-analyzer/icinga/Manifest4
-rw-r--r--net-analyzer/icinga/icinga-1.0.2.ebuild43
-rw-r--r--net-analyzer/icinga/metadata.xml10
4 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
new file mode 100644
index 000000000..0bda5ba9f
--- /dev/null
+++ b/net-analyzer/icinga/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/icinga
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 14 Jul 2010; Matthew Thode (prometheanfire) <mthode@mthode.org>
+ +icinga-1.0.2.ebuild, +metadata.xml:
+ New Ebuild for bug 271339 thanks to chithead
+
diff --git a/net-analyzer/icinga/Manifest b/net-analyzer/icinga/Manifest
new file mode 100644
index 000000000..593fb0739
--- /dev/null
+++ b/net-analyzer/icinga/Manifest
@@ -0,0 +1,4 @@
+DIST icinga-1.0.2.tar.gz 8446607 RMD160 782ebbad8ce4e88a3e214ba12802fe7d968ce851 SHA1 d4325b87369d9bbfc1d52da071e8cc24bdc3d2dd SHA256 3e827712cef7afd074048e5bf48140744c2bdd9607235997e947d1eb8c7665c4
+EBUILD icinga-1.0.2.ebuild 898 RMD160 7b0b621da09dccf14c0b8d7fe5f719a85b385777 SHA1 011ecea521c3a9b88a34897415cf4a31cd75fdc5 SHA256 9ecc2c317014d01d811183acb33789523df983366d89679982d36c9f3653e031
+MISC ChangeLog 273 RMD160 edddb896784bf2db535de407687e5c08b370699d SHA1 fd9723fcc1a128416b7e098416190538e6a463e0 SHA256 9808d3839e4542fac7c561c970c5b045e79c70411215e12a489a688fce03c73d
+MISC metadata.xml 322 RMD160 9cf9330dfae317dba606225f5b5031e1873ff937 SHA1 dbdb644e6993c4021de657fbfd825dbbcadbfd02 SHA256 63c458bdecf6838907f9fd09270f66bc1c760b292b8636fbd52895c9e69d07ec
diff --git a/net-analyzer/icinga/icinga-1.0.2.ebuild b/net-analyzer/icinga/icinga-1.0.2.ebuild
new file mode 100644
index 000000000..63eb2b28b
--- /dev/null
+++ b/net-analyzer/icinga/icinga-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A monitoring system based on Nagios"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbi ssl"
+
+RDEPEND="dbi? ( dev-db/libdbi-drivers )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup icinga
+ enewuser icinga -1 -1 -1 icinga
+}
+
+src_configure() {
+ econf --with-posix-regex \
+ $(use_enable ssl) \
+ $(use_enable dbi idoutils)
+}
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-unstripped install-api install-init install-config install-commandmode || die
+ if use dbi; then
+ emake DESTDIR="${D}" install-idoutils || die
+ fi
+ dodoc README THANKS AUTHORS || die "dodoc failed"
+}
diff --git a/net-analyzer/icinga/metadata.xml b/net-analyzer/icinga/metadata.xml
new file mode 100644
index 000000000..e05d2ea12
--- /dev/null
+++ b/net-analyzer/icinga/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription lang="en">A rebuild of nagios from the ground up</longdescription>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+