summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-01-14 18:47:53 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-01-14 18:47:53 +0000
commit994021f93db7ebbfa9128589cb6e5371ca482c9a (patch)
treec368d91c55c962051af3d07d5f15ab87e93d24df /net-analyzer/netwatch/netwatch-1.3.0.1.ebuild
parentmedia-radio/xlog: Added minor bugfix from upstream (diff)
downloadsunrise-994021f93db7ebbfa9128589cb6e5371ca482c9a.tar.gz
sunrise-994021f93db7ebbfa9128589cb6e5371ca482c9a.tar.bz2
sunrise-994021f93db7ebbfa9128589cb6e5371ca482c9a.zip
net-analyzer/netwatch: Version bump to 1.3.0.1.
replaced dobin by dosbin. svn path=/sunrise/; revision=7640
Diffstat (limited to 'net-analyzer/netwatch/netwatch-1.3.0.1.ebuild')
-rw-r--r--net-analyzer/netwatch/netwatch-1.3.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/netwatch/netwatch-1.3.0.1.ebuild b/net-analyzer/netwatch/netwatch-1.3.0.1.ebuild
new file mode 100644
index 000000000..dc7504416
--- /dev/null
+++ b/net-analyzer/netwatch/netwatch-1.3.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="Ethernet/PPP IP Packet Monitor"
+HOMEPAGE="http://www.slctech.org/~mackay/netwatch.html"
+SRC_URI="http://www.slctech.org/~mackay/NETWATCH/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+src_install() {
+ dosbin netresolv netwatch || die "dobin failed"
+
+ doman netwatch.1 || die "doman failed"
+ dodoc BUGS CHANGES README* TODO || die "dodoc failed"
+
+ if use doc; then
+ dohtml NetwatchKeyCommands.html || die "dohtml failed"
+ fi
+}
+