summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2006-11-29 19:06:56 +0000
committerRaúl Porcel <armin76@gentoo.org>2006-11-29 19:06:56 +0000
commitd84325ee639347d9c8dd8de1bd58d2cf81005f40 (patch)
treeeecba4abab670002eda027497d2a9bc031f31993 /net-ftp/foff/foff-0.99.5.ebuild
parentnet-p2p/deluge: Add python_mod_compile using python eclass, and fix deps(agai... (diff)
downloadsunrise-d84325ee639347d9c8dd8de1bd58d2cf81005f40.tar.gz
sunrise-d84325ee639347d9c8dd8de1bd58d2cf81005f40.tar.bz2
sunrise-d84325ee639347d9c8dd8de1bd58d2cf81005f40.zip
net-ftp/foff: New ebuild for bug 156638
svn path=/sunrise/; revision=2054
Diffstat (limited to 'net-ftp/foff/foff-0.99.5.ebuild')
-rw-r--r--net-ftp/foff/foff-0.99.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-ftp/foff/foff-0.99.5.ebuild b/net-ftp/foff/foff-0.99.5.ebuild
new file mode 100644
index 000000000..482b249b1
--- /dev/null
+++ b/net-ftp/foff/foff-0.99.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils python multilib
+
+DESCRIPTION="FTP client in Python and GTK."
+HOMEPAGE="http://foff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pygtk-2.6"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir "/usr/$(get_libdir)/${PN}"
+ insinto "/usr/$(get_libdir)/${PN}"
+ doins *.py foff_logo00.png *.glade *.gladep Copying.txt
+
+ # The app needs to be executed from the installed dir
+ echo -e "#!/bin/bash \ncd "/usr/$(get_libdir)/${PN}" \n\
+/usr/bin/python ${PN}.py" >> foff
+
+ dobin foff
+
+ dodoc Readme.txt ChangeLog.txt
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/${PN}"
+}