summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2007-04-14 20:27:50 +0000
committerMike Pagano <mpagano@gentoo.org>2007-04-14 20:27:50 +0000
commit4a6ca201cfddfb02bd63d934317ebf58af562049 (patch)
treeb9773427164b4a9230444fd1b7c9bff36024ba46 /net-im/pyxmpp
parentsys-power/acpi-support: integrate w/hibernate-script, fix use-conditional sta... (diff)
downloadsunrise-4a6ca201cfddfb02bd63d934317ebf58af562049.tar.gz
sunrise-4a6ca201cfddfb02bd63d934317ebf58af562049.tar.bz2
sunrise-4a6ca201cfddfb02bd63d934317ebf58af562049.zip
net-im/pyxmpp: Fixed broken make file and corrected SRC_URI and HOMEPAGE as it moved.
svn path=/sunrise/; revision=3424
Diffstat (limited to 'net-im/pyxmpp')
-rw-r--r--net-im/pyxmpp/ChangeLog3
-rw-r--r--net-im/pyxmpp/Manifest3
-rwxr-xr-xnet-im/pyxmpp/pyxmpp-1.0.0-r1.ebuild35
3 files changed, 40 insertions, 1 deletions
diff --git a/net-im/pyxmpp/ChangeLog b/net-im/pyxmpp/ChangeLog
index 525111b9a..3431e8172 100644
--- a/net-im/pyxmpp/ChangeLog
+++ b/net-im/pyxmpp/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Apr 2007; Michael Pagano <mpagano@gmail.com> +pyxmpp-1.0.0-r1.ebuild:
+ Fixed broken make file and corrected SRC_URI and HOMEPAGE as it moved.
+
20 Jun 2006; Michael Pagano <mpagano@gmail.com> +pyxmpp-1.0.0.ebuild:
New ebuild for bug 135287
diff --git a/net-im/pyxmpp/Manifest b/net-im/pyxmpp/Manifest
index 5d3b9bce2..9f97d4745 100644
--- a/net-im/pyxmpp/Manifest
+++ b/net-im/pyxmpp/Manifest
@@ -1,4 +1,5 @@
DIST pyxmpp-1.0.0.tar.gz 669021 RMD160 148d07c97ca715985a57984fdc6c228dbe1fb019 SHA1 6a8d88ed79153175698cd0ffc914ea37c3f526ce SHA256 924ba0cde1e630b53784623cdaab35f0da6e81e7b8a11e6927cd38420a781267
+EBUILD pyxmpp-1.0.0-r1.ebuild 886 RMD160 eda15babc69e3917cf5897c9b8309819c81a524c SHA1 bb2dd69649c98979677bdceebc6a783a4e59ecd4 SHA256 fef2ef5ee9cd2747b7d4dfeb3fa8b8495270cff1507ce1cf690e532c014343d4
EBUILD pyxmpp-1.0.0.ebuild 907 RMD160 49a6236cf53ca71ef3dba9fbbb8b1f6927249187 SHA1 43374bdba4aa5e112cc6c432b262c74a8efbf640 SHA256 a51a913847f2cf15269347dcb7ae639c4e7c540efba3655f2e515d3accabf4b3
-MISC ChangeLog 215 RMD160 cf8ecd4f13a7863e571c6becb6b35b577f5f242f SHA1 6a779687ce6addeb1926a822481a059b1b663f30 SHA256 851f605dd8a0522113dd87b0505e00e36a07c37bfe164a35aff42da3d028f2f8
+MISC ChangeLog 364 RMD160 eecfab2eb038a43de254fbb8406e235f329a8dd5 SHA1 9c6fe44fb00445eefd8ed2986131bb11ebe98644 SHA256 f6b4e74baf10db30848f0429f5583b28b28ddfd93afb7fd20e4a2598b25e0b69
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-im/pyxmpp/pyxmpp-1.0.0-r1.ebuild b/net-im/pyxmpp/pyxmpp-1.0.0-r1.ebuild
new file mode 100755
index 000000000..cda725386
--- /dev/null
+++ b/net-im/pyxmpp/pyxmpp-1.0.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A Python XMPP (RFC 3920,3921) and Jabber implementation"
+HOMEPAGE="http://pyxmpp.jajcus.net/"
+SRC_URI="http://pyxmpp.jajcus.net/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-libs/libxml2-2.6.23"
+
+RDEPEND=">=dev-python/dnspython-1.3.2
+ >=dev-python/m2crypto-0.13.1"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxml2 python ; then
+ eerror "To build pyxmpp, libxml2 must be built with python"
+ eerror "bindings. To continue merging pyxmpp, you must first "
+ eerror "recompile libxml2 with the python use flag enabled"
+ die "pyxmpp requires libxml2 with USE=python"
+ fi
+}
+
+src_compile() {
+ emake DESTDIR="${D}" build || die "emake build failed"
+ dohtml -r doc/*
+}