summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Grant (dgrant) <davidgrant@gmail.com>2006-07-11 02:13:05 +0000
committerDavid Grant (dgrant) <davidgrant@gmail.com>2006-07-11 02:13:05 +0000
commit669cef86f272215ff51f1204a893b15568d1c7ad (patch)
tree5f4ff404d5c5c9c42832003f2ea1bc8a88d52042 /net-mail/gmail-notify/gmail-notify-1.6.1.ebuild
parentnet-mail/gmail-notify: leading whitespace (diff)
downloadsunrise-669cef86f272215ff51f1204a893b15568d1c7ad.tar.gz
sunrise-669cef86f272215ff51f1204a893b15568d1c7ad.tar.bz2
sunrise-669cef86f272215ff51f1204a893b15568d1c7ad.zip
net-mail/gmail-notify: incorporated suggestions from Tristan Heaven
svn path=/sunrise/; revision=586
Diffstat (limited to 'net-mail/gmail-notify/gmail-notify-1.6.1.ebuild')
-rw-r--r--net-mail/gmail-notify/gmail-notify-1.6.1.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild b/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild
index 0413598a3..1d4411231 100644
--- a/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild
+++ b/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit python
+inherit python eutils
DESCRIPTION="Gmail Notifier is a Linux alternative for the notifier program released by Google"
-HOMEPAGE="http://gmail-notify.sf.net"
+HOMEPAGE="http://gmail-notify.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -14,10 +14,9 @@ KEYWORDS="~x86"
IUSE=""
RDEPEND="virtual/python
- >=dev-python/pygtk-2.0*
- >=x11-libs/gtk+-2.4*"
-DEPEND="${RDEPEND}
- app-arch/bzip2"
+ >=dev-python/pygtk-2.0
+ >=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
@@ -27,16 +26,16 @@ src_install() {
#Install docs
dodoc README
- rm -f README
#Install all python files into site-packages
insinto ${INST_DIR}
- doins -r *
+ doins *.py *.jpg *.png langs.xml pytrayicon.so notifier.conf.sample
#Install a script in /usr/bin
echo "#!/bin/bash" > gmail-notify
echo "exec /usr/bin/python ${INST_DIR}/notifier.py \"\$1\"" >> gmail-notify
dobin gmail-notify
+ make_wrapper gmail-notify "/usr/bin/python ${INST_DIR}/notifier.py"
}
pkg_postinst() {