summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jackson <mjo@gentoo.org>2010-03-28 16:22:22 +0000
committerMartin Jackson <mjo@gentoo.org>2010-03-28 16:22:22 +0000
commit06789421fc235588c6da292494f06eae8de69a01 (patch)
tree8639081e8b8b656ef1cde27f268e2d6c44d29b2a /net-mail/postfix-logwatch/postfix-logwatch-1.39.04.ebuild
parentnet-mail/amavis-logwatch: Project moved to Sourceforge, update URIs. (diff)
downloadsunrise-06789421fc235588c6da292494f06eae8de69a01.tar.gz
sunrise-06789421fc235588c6da292494f06eae8de69a01.tar.bz2
sunrise-06789421fc235588c6da292494f06eae8de69a01.zip
net-mail/postfix-logwatch: Version bump to support the latest Postfix development release.
svn path=/sunrise/; revision=10356
Diffstat (limited to 'net-mail/postfix-logwatch/postfix-logwatch-1.39.04.ebuild')
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.39.04.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.39.04.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.39.04.ebuild
new file mode 100644
index 000000000..b56760f97
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.39.04.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://logreporters.sourceforge.net/"
+SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="logwatch"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # The default make target just outputs instructions. We don't want
+ # the user to see these, so we avoid emake.
+ :
+}
+
+src_install() {
+ # There are two different "versions" of the package in the
+ # tarball: a standalone executable and a logwatch filter. The
+ # standalone is always installed. However, the logwatch filter is
+ # only installed with USE="logwatch".
+ dodoc Bugs Changes README ${PN}.conf-topn \
+ || die "failed to install documentation"
+
+ doman ${PN}.1 || die "failed to install man page"
+ dohtml ${PN}.1.html || die "failed to install html documentation"
+ dobin ${PN} || die "failed to install executable"
+ insinto /etc
+ doins ${PN}.conf || die "failed to install config file"
+
+ if use logwatch; then
+ # Remove the taint mode (-T) switch from the header of the
+ # standalone executable, and save the result as our logwatch
+ # filter.
+ sed 's~^#!/usr/bin/perl -T$~#!/usr/bin/perl~' ${PN} > postfix \
+ || die "failed to remove the perl taint switch"
+
+ insinto /etc/logwatch/scripts/services
+ doins postfix || die "failed to install the 'postfix' logwatch filter"
+
+ insinto /etc/logwatch/conf/services
+ newins ${PN}.conf postfix.conf \
+ || die "failed to install the logwatch 'postfix.conf' file"
+ fi
+}