summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2006-06-25 20:57:57 +0000
committerJakub Moc <jakub@gentoo.org>2006-06-25 20:57:57 +0000
commita39110e1637cada89ce3f6168947c42ff64efcdf (patch)
tree5b788b32ae5bdb8efa665c871c9e797e47ee353e /net-mail
parentNew libiqxmlrpc Ebuild for bug 71785 (diff)
downloadsunrise-a39110e1637cada89ce3f6168947c42ff64efcdf.tar.gz
sunrise-a39110e1637cada89ce3f6168947c42ff64efcdf.tar.bz2
sunrise-a39110e1637cada89ce3f6168947c42ff64efcdf.zip
net-mail/simscan - facelift
svn path=/sunrise/; revision=279
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/simscan/Manifest8
-rw-r--r--net-mail/simscan/simscan-1.1.ebuild46
2 files changed, 25 insertions, 29 deletions
diff --git a/net-mail/simscan/Manifest b/net-mail/simscan/Manifest
index 3570a5af5..0ade2f148 100644
--- a/net-mail/simscan/Manifest
+++ b/net-mail/simscan/Manifest
@@ -1,8 +1,8 @@
DIST simscan-1.1.tar.gz 130114 RMD160 080ec02382e15a93b09719573951783d907bc26b SHA1 9bc0d085f851e0823539e72da2efd238d406dc63 SHA256 0bf09145b003e93e4986eead18778ce9ae4af691c3a99e180bdd04116c082813
-EBUILD simscan-1.1.ebuild 3716 RMD160 13bfebb40a3959e4081d2b157ef0cc0f300e6e37 SHA1 08ad7a4671cae1e5b2d939a44c826ca75c23ce39 SHA256 83500c303c25dd4c5c3d0227e5151e843b95a8b8f549c8814b536ec5621c1870
-MD5 2d6e44afd30f9f6c210218d8f98e0957 simscan-1.1.ebuild 3716
-RMD160 13bfebb40a3959e4081d2b157ef0cc0f300e6e37 simscan-1.1.ebuild 3716
-SHA256 83500c303c25dd4c5c3d0227e5151e843b95a8b8f549c8814b536ec5621c1870 simscan-1.1.ebuild 3716
+EBUILD simscan-1.1.ebuild 3643 RMD160 4fa26745f728fffe70dd7e50d60c350c7e851df1 SHA1 50149bb4a9ab0c5ae47c854e39353bebd9e8de89 SHA256 5988afa32c6446e061fc2dcb409635ebb28cbd9da6b6b257748319e099f04aef
+MD5 5c352fba6ea022edfa3c906580325198 simscan-1.1.ebuild 3643
+RMD160 4fa26745f728fffe70dd7e50d60c350c7e851df1 simscan-1.1.ebuild 3643
+SHA256 5988afa32c6446e061fc2dcb409635ebb28cbd9da6b6b257748319e099f04aef simscan-1.1.ebuild 3643
MISC ChangeLog 253 RMD160 185f953f4415edb351a3d6496e3a2efe87ce5460 SHA1 1a59da234695c9abe1b9ffe2a9afc37add799f97 SHA256 36acfbdf14dedb060a1c7e90665f674f56b69b91de0168b67522b9087ef58b3a
MD5 caa97ba8c0665de573504a591047da1b ChangeLog 253
RMD160 185f953f4415edb351a3d6496e3a2efe87ce5460 ChangeLog 253
diff --git a/net-mail/simscan/simscan-1.1.ebuild b/net-mail/simscan/simscan-1.1.ebuild
index b4a4cb356..f18eee60b 100644
--- a/net-mail/simscan/simscan-1.1.ebuild
+++ b/net-mail/simscan/simscan-1.1.ebuild
@@ -4,31 +4,27 @@
inherit eutils
-DESCRIPTION="Simscan is a simple program that enables qmail-smtpd to reject viruses, spam, and block attachments during the SMTP conversation"
+DESCRIPTION="A simple program that enables qmail-smtpd to reject viruses, spam, and block attachments during the SMTP conversation"
HOMEPAGE="http://www.inter7.com/?page=simscan"
SRC_URI="http://www.inter7.com/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="clamav attachement custom-smtp-reject dropmsg regex quarantine perdomain
-received spamassassin passthru"
+IUSE="attachment clamav custom-smtp-reject dropmsg received passthru perdomain regex quarantine spamassassin"
-DEPEND="
- clamav? ( app-antivirus/clamav )
- attachement? ( net-mail/ripmime )
+DEPEND="clamav? ( app-antivirus/clamav )
+ attachment? ( net-mail/ripmime )
spamassassin? ( mail-filter/spamassassin )
- regex? ( dev-libs/libpcre )
-"
+ regex? ( dev-libs/libpcre )"
RDEPEND="${DEPEND}
- virtual/qmail
-"
+ virtual/qmail"
-RESTRICT=strip
+RESTRICT="strip"
pkg_setup() {
enewgroup clamav
- enewuser simscan -1 -1 /dev/null clamav '-c "simscan user (portage)"'
+ enewuser simscan -1 -1 /dev/null clamav
}
src_compile() {
@@ -40,7 +36,7 @@ src_compile() {
myconf="${myconf} --enable-clamav=n"
fi
- if use attachement ; then
+ if use attachment ; then
myconf="${myconf} --enable-attach=y"
myconf="${myconf} --enable-ripmime=/usr/bin/ripmime"
else
@@ -122,34 +118,34 @@ src_install() {
}
pkg_postinst() {
- einfo ""
+ einfo
if use custom-smtp-reject ; then
- einfo "Becareful, if you use the \"custom-smtp-reject\" flag you will"
- einfo "have many problems if qmail was not patched with"
- einfo "qmail-queue-custom-error.patch"
- einfo ""
+ ewarn "Be careful when using the \"custom-smtp-reject\" flag you will"
+ ewarn "have many problems if qmail was not patched with"
+ ewarn "qmail-queue-custom-error.patch"
+ ewarn
ewarn "If your not sure, re-emerge simscan without this flag"
- einfo ""
+ ewarn
fi
einfo "Now update the simscan configuration files :"
ewarn "You have to do that after clamav or spamassassin update"
- einfo ""
+ einfo
einfo "/var/qmail/bin/simscanmk"
einfo "`/var/qmail/bin/simscanmk`"
- einfo ""
+ einfo
einfo "/var/qmail/bin/simscanmk -g"
einfo "`/var/qmail/bin/simscanmk -g`"
- einfo ""
+ einfo
einfo "You must have qmail with QMAILQUEUE patch"
einfo "And, in order use simscan, edit your tcp.qmail-smtpd rules"
einfo "and update as follow (for example only)"
- einfo ""
+ einfo
einfo ":allow,QMAILQUEUE=\"/var/qmail/bin/simscan\""
- einfo ""
+ einfo
ewarn "Read the documentation and personnalize /var/qmail/control/simcontrol"
- einfo ""
+ einfo
}