summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jackson <mjo@gentoo.org>2010-03-17 22:01:41 +0000
committerMartin Jackson <mjo@gentoo.org>2010-03-17 22:01:41 +0000
commitd0132e0cd8b520dfd62c66857a555ce628a8d48a (patch)
tree2167e143b2981b86142ca150cd86d6586b27bfbc /net-mail
parentnet-mail/amavis-logwatch: New ebuild to address bug 309077. (diff)
downloadsunrise-d0132e0cd8b520dfd62c66857a555ce628a8d48a.tar.gz
sunrise-d0132e0cd8b520dfd62c66857a555ce628a8d48a.tar.bz2
sunrise-d0132e0cd8b520dfd62c66857a555ce628a8d48a.zip
net-mail/postfix-logwatch: New ebuild to address bug 309075.
svn path=/sunrise/; revision=10298
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/postfix-logwatch/ChangeLog8
-rw-r--r--net-mail/postfix-logwatch/Manifest4
-rw-r--r--net-mail/postfix-logwatch/metadata.xml8
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.39.03.ebuild51
4 files changed, 71 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/ChangeLog b/net-mail/postfix-logwatch/ChangeLog
new file mode 100644
index 000000000..456d5197d
--- /dev/null
+++ b/net-mail/postfix-logwatch/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-mail/postfix-logwatch
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 17 Mar 2010; Michael Orlitzky <michael@orlitzky.com>
+ +postfix-logwatch-1.39.03.ebuild, +metadata.xml:
+ New ebuild to address bug 309075.
+
diff --git a/net-mail/postfix-logwatch/Manifest b/net-mail/postfix-logwatch/Manifest
new file mode 100644
index 000000000..b6fb0a332
--- /dev/null
+++ b/net-mail/postfix-logwatch/Manifest
@@ -0,0 +1,4 @@
+DIST postfix-logwatch-1.39.03.tgz 111560 RMD160 d3f53f2513c1921f4522fe1f131464c971bc1d40 SHA1 9c1fefdc1a58b3cdc0d416c19eccbd43bc18001a SHA256 dfa153be55f95118b267ac5d788b2ef8a03069e091421a897612d3335d3cbd92
+EBUILD postfix-logwatch-1.39.03.ebuild 1607 RMD160 9793f6571505701fd4e5402e7cff88cc36f9535b SHA1 5fca3bc0a579a2183a152c842c95f8a9a62b9272 SHA256 eb8b52125b4514e1e73b1e898c5b9ae524258d8421ba880e8969bf23810dc051
+MISC ChangeLog 269 RMD160 f191f7dd1a1440cad2ac6dcf00c18177687e23ef SHA1 ad1c3836e10b4ea69f01b04581552e1fcc5ae8f6 SHA256 9db1c194d60ff10284ba1a28cff687097489f5b0ceebe701b52b408faa789eca
+MISC metadata.xml 273 RMD160 0dac457c6273ae4054c501e2470737f98ed6e2d2 SHA1 e378e7e440ca21f7490e07731a44170259221b8d SHA256 85365f3b9d586f4fb14cd47295e40e9fbb72f70a4dfb0fc4aaabda4088104d8d
diff --git a/net-mail/postfix-logwatch/metadata.xml b/net-mail/postfix-logwatch/metadata.xml
new file mode 100644
index 000000000..dab3714f9
--- /dev/null
+++ b/net-mail/postfix-logwatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+<use>
+ <flag name='logwatch'>Install filters for use with <pkg>sys-apps/logwatch</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.39.03.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.39.03.ebuild
new file mode 100644
index 000000000..7204bc56b
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.39.03.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://www.mikecappella.com/logwatch/"
+SRC_URI="${HOMEPAGE}/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="logwatch"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # The default make target just outputs instructions. We don't want
+ # the user to see these, so we avoid emake.
+ :
+}
+
+src_install() {
+ # There are two different "versions" of the package in the
+ # tarball: a standalone executable and a logwatch filter. The
+ # standalone is always installed. However, the logwatch filter is
+ # only installed with USE="logwatch".
+ dodoc Bugs Changes README ${PN}.conf-topn \
+ || die "failed to install documentation"
+
+ doman ${PN}.1 || die "failed to install man page"
+ dohtml ${PN}.1.html || die "failed to install html documentation"
+ dobin ${PN} || die "failed to install executable"
+ insinto /etc
+ doins ${PN}.conf || die "failed to install config file"
+
+ if use logwatch; then
+ # Remove the taint mode (-T) switch from the header of the
+ # standalone executable, and save the result as our logwatch
+ # filter.
+ sed 's~^#!/usr/bin/perl -T$~#!/usr/bin/perl~' ${PN} > postfix \
+ || die "failed to remove the perl taint switch"
+
+ insinto /etc/logwatch/scripts/services
+ doins postfix || die "failed to install the 'postfix' logwatch filter"
+
+ insinto /etc/logwatch/conf/services
+ newins ${PN}.conf postfix.conf \
+ || die "failed to install the logwatch 'postfix.conf' file"
+ fi
+}