summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2006-06-25 21:16:06 +0000
committerJakub Moc <jakub@gentoo.org>2006-06-25 21:16:06 +0000
commitd8b9cee6fc16345fbe32ed9632b273e96e90c7a6 (patch)
tree0b7881ded4e131299057fb5e70009b49ebb22555 /net-mail
parentAdded ttmpeg2 use-flag to ttcut ebuild - the second (diff)
downloadsunrise-d8b9cee6fc16345fbe32ed9632b273e96e90c7a6.tar.gz
sunrise-d8b9cee6fc16345fbe32ed9632b273e96e90c7a6.tar.bz2
sunrise-d8b9cee6fc16345fbe32ed9632b273e96e90c7a6.zip
net-mail/simscan - another facelift
svn path=/sunrise/; revision=282
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/simscan/Manifest8
-rw-r--r--net-mail/simscan/simscan-1.1.ebuild52
2 files changed, 18 insertions, 42 deletions
diff --git a/net-mail/simscan/Manifest b/net-mail/simscan/Manifest
index 0ade2f148..11f34ecb6 100644
--- a/net-mail/simscan/Manifest
+++ b/net-mail/simscan/Manifest
@@ -1,8 +1,8 @@
DIST simscan-1.1.tar.gz 130114 RMD160 080ec02382e15a93b09719573951783d907bc26b SHA1 9bc0d085f851e0823539e72da2efd238d406dc63 SHA256 0bf09145b003e93e4986eead18778ce9ae4af691c3a99e180bdd04116c082813
-EBUILD simscan-1.1.ebuild 3643 RMD160 4fa26745f728fffe70dd7e50d60c350c7e851df1 SHA1 50149bb4a9ab0c5ae47c854e39353bebd9e8de89 SHA256 5988afa32c6446e061fc2dcb409635ebb28cbd9da6b6b257748319e099f04aef
-MD5 5c352fba6ea022edfa3c906580325198 simscan-1.1.ebuild 3643
-RMD160 4fa26745f728fffe70dd7e50d60c350c7e851df1 simscan-1.1.ebuild 3643
-SHA256 5988afa32c6446e061fc2dcb409635ebb28cbd9da6b6b257748319e099f04aef simscan-1.1.ebuild 3643
+EBUILD simscan-1.1.ebuild 3225 RMD160 23294d3f9573645aae8f137031f312652a6a9514 SHA1 7738a5ccbf7383722eaff7389d64c70e5d48c446 SHA256 0d7aa70ac43629bbd7367e876127a5eee1418510ddf9d40801aae1797d2428a0
+MD5 218ad50f40e7bf2f2446af3fce802caa simscan-1.1.ebuild 3225
+RMD160 23294d3f9573645aae8f137031f312652a6a9514 simscan-1.1.ebuild 3225
+SHA256 0d7aa70ac43629bbd7367e876127a5eee1418510ddf9d40801aae1797d2428a0 simscan-1.1.ebuild 3225
MISC ChangeLog 253 RMD160 185f953f4415edb351a3d6496e3a2efe87ce5460 SHA1 1a59da234695c9abe1b9ffe2a9afc37add799f97 SHA256 36acfbdf14dedb060a1c7e90665f674f56b69b91de0168b67522b9087ef58b3a
MD5 caa97ba8c0665de573504a591047da1b ChangeLog 253
RMD160 185f953f4415edb351a3d6496e3a2efe87ce5460 ChangeLog 253
diff --git a/net-mail/simscan/simscan-1.1.ebuild b/net-mail/simscan/simscan-1.1.ebuild
index f18eee60b..0482c96b3 100644
--- a/net-mail/simscan/simscan-1.1.ebuild
+++ b/net-mail/simscan/simscan-1.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://www.inter7.com/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="attachment clamav custom-smtp-reject dropmsg received passthru perdomain regex quarantine spamassassin"
+IUSE="attachment clamav custom-smtp-reject dropmsg received passthru per-domain regex quarantine spamassassin"
DEPEND="clamav? ( app-antivirus/clamav )
attachment? ( net-mail/ripmime )
@@ -29,12 +29,14 @@ pkg_setup() {
src_compile() {
local myconf
-
- if use clamav ; then
- myconf="${myconf} --enable-clamav=y"
- else
- myconf="${myconf} --enable-clamav=n"
- fi
+
+ for flag in clamav custom-smtp-reject dropmsg per-domain received ; do
+ if use ${flag} ; then
+ myconf="${myconf} --enable-${flag}=y"
+ else
+ myconf="${myconf} --enable-${flag}=n"
+ fi
+ done
if use attachment ; then
myconf="${myconf} --enable-attach=y"
@@ -43,18 +45,6 @@ src_compile() {
myconf="${myconf} --enable-attach=n"
fi
- if use custom-smtp-reject ; then
- myconf="${myconf} --enable-custom-smtp-reject=y"
- else
- myconf="${myconf} --enable-custom-smtp-reject=n"
- fi
-
- if use dropmsg ; then
- myconf="${myconf} --enable-dropmsg=y"
- else
- myconf="${myconf} --enable-dropmsg=n"
- fi
-
if use regex ; then
myconf="${myconf} --enable-regex=y"
myconf="${myconf} --enable-pcre"
@@ -64,18 +54,6 @@ src_compile() {
use quarantine && myconf="${myconf} --enable-quarantinedir"
- if use perdomain ; then
- myconf="${myconf} --enable-per-domain=y"
- else
- myconf="${myconf} --enable-per-domain=n"
- fi
-
- if use received ; then
- myconf="${myconf} --enable-received=y"
- else
- myconf="${myconf} --enable-received=n"
- fi
-
if use spamassassin ; then
myconf="${myconf} --enable-spam=y"
if use passthru ; then
@@ -94,7 +72,6 @@ src_compile() {
src_install() {
einfo "Installing documentation and contrib files"
dodoc AUTHORS README TODO
-
docinto contrib
dodoc contrib/*.patch
@@ -108,7 +85,7 @@ src_install() {
fowners simscan /var/qmail/simscan /var/qmail/bin/simscan
fperms 4711 /var/qmail/bin/simscan
- if use perdomain ; then
+ if use per-domain ; then
einfo "Setting default configuration..."
echo ':clam=yes,spam=yes' > simcontrol
insopts -o root -g root -m 644
@@ -118,9 +95,8 @@ src_install() {
}
pkg_postinst() {
- einfo
-
if use custom-smtp-reject ; then
+ ewarn
ewarn "Be careful when using the \"custom-smtp-reject\" flag you will"
ewarn "have many problems if qmail was not patched with"
ewarn "qmail-queue-custom-error.patch"
@@ -130,7 +106,7 @@ pkg_postinst() {
fi
einfo "Now update the simscan configuration files :"
- ewarn "You have to do that after clamav or spamassassin update"
+ einfo "You have to do that after clamav or spamassassin update"
einfo
einfo "/var/qmail/bin/simscanmk"
einfo "`/var/qmail/bin/simscanmk`"
@@ -140,12 +116,12 @@ pkg_postinst() {
einfo
einfo "You must have qmail with QMAILQUEUE patch"
- einfo "And, in order use simscan, edit your tcp.qmail-smtpd rules"
+ einfo "In order use simscan, edit your tcp.qmail-smtpd rules"
einfo "and update as follow (for example only)"
einfo
einfo ":allow,QMAILQUEUE=\"/var/qmail/bin/simscan\""
einfo
- ewarn "Read the documentation and personnalize /var/qmail/control/simcontrol"
+ einfo "Read the documentation and personalize /var/qmail/control/simcontrol"
einfo
}