summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2008-09-11 19:01:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2008-09-11 19:01:05 +0000
commit688238a6c9a6aee706ab56fdd692ac511ba95ada (patch)
treeef392b093ee6db7a04674a2fd752ac83dad47152 /net-misc/anyremote
parentnet-misc/kanyremote: New Ebuild for bug #209689 (diff)
downloadsunrise-688238a6c9a6aee706ab56fdd692ac511ba95ada.tar.gz
sunrise-688238a6c9a6aee706ab56fdd692ac511ba95ada.tar.bz2
sunrise-688238a6c9a6aee706ab56fdd692ac511ba95ada.zip
net-misc/anyremote: Upstream patch for compilation failure when --disable-bluez was used
svn path=/sunrise/; revision=7067
Diffstat (limited to 'net-misc/anyremote')
-rw-r--r--net-misc/anyremote/ChangeLog4
-rw-r--r--net-misc/anyremote/Manifest5
-rw-r--r--net-misc/anyremote/anyremote-4.8.1.ebuild (renamed from net-misc/anyremote/anyremote-4.8.1-r1.ebuild)8
-rw-r--r--net-misc/anyremote/files/btio.patch38
4 files changed, 53 insertions, 2 deletions
diff --git a/net-misc/anyremote/ChangeLog b/net-misc/anyremote/ChangeLog
index 2779cdfb2..3eb2deeeb 100644
--- a/net-misc/anyremote/ChangeLog
+++ b/net-misc/anyremote/ChangeLog
@@ -3,6 +3,10 @@
# $Header: $
11 Sep 2008; Markos Chandras (hwoarang) <gentoo@silverarrow.gr>
+ +anyremote-4.8.1.ebuild, -anyremote-4.8.1-r1.ebuild, +files/btio.patch:
+ Upstream patch for compilation failure when --disable-bluez was used
+
+ 11 Sep 2008; Markos Chandras (hwoarang) <gentoo@silverarrow.gr>
-anyremote-4.8.1.ebuild, +anyremote-4.8.1-r1.ebuild:
Drop kde,gnome use flags
diff --git a/net-misc/anyremote/Manifest b/net-misc/anyremote/Manifest
index eecaa182d..cc09c164d 100644
--- a/net-misc/anyremote/Manifest
+++ b/net-misc/anyremote/Manifest
@@ -1,4 +1,5 @@
+AUX btio.patch 765 RMD160 37df02d96fedb20908d11987618af60f1c40ec2c SHA1 bfd5116853f6822d3075fd87b26a2d880511464f SHA256 703d7046796a85b4524aa61cccc3148fbb2be248d87dc62c1616d7557538bf25
DIST anyremote-4.8.1.tar.gz 1523548 RMD160 385986a7d861f1f353168a8d86cff758dac75780 SHA1 c794bbedfd7a214109d3fecfa7b804b7aa0eb1b6 SHA256 24971870cb6c83dcc1dad4a112890fa9cfe7b32af9211995afaf8d1d3932ed14
-EBUILD anyremote-4.8.1-r1.ebuild 738 RMD160 f1a7a77e3cd38c509260fcc4386b574b2d76b819 SHA1 2219821d07e9f722061ef36e3ee33622e60a8e74 SHA256 997d7a0946854377156788cd65018ff3e8f30cb8d7071ab6b539410ad9d39e44
-MISC ChangeLog 406 RMD160 2327e9862ef688c39a9cc627ea6bcf0b52775bc5 SHA1 be5dfd2df6267560def2fefcc6014c331ba54cc3 SHA256 d49c1f7b2e8fe3fb4474dd48959d0771f4d737b109ddd61e7f34fe3321e92c8d
+EBUILD anyremote-4.8.1.ebuild 831 RMD160 e0c043849208e9cafc825133a0498de5def8ffd5 SHA1 8d6377aedfddb737811ba9effdfc2d4b2156e92d SHA256 7c379f8125ffa4ce81d189309f4647b3bd45aa09c517639d5d814cb915a011f9
+MISC ChangeLog 618 RMD160 a5e878cfd951cbc38839150c4213575b933ed887 SHA1 1ee99d515c8c40f50c19a769725acf6ac77d8e39 SHA256 a4eae52233db418d54a400a76f6763c0829b6c18afe2cb3e34bece6f91591071
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-misc/anyremote/anyremote-4.8.1-r1.ebuild b/net-misc/anyremote/anyremote-4.8.1.ebuild
index 01fd447d5..7b1b646bd 100644
--- a/net-misc/anyremote/anyremote-4.8.1-r1.ebuild
+++ b/net-misc/anyremote/anyremote-4.8.1.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit eutils
+
DESCRIPTION="Anyremote provides wireless Bluetooth or infrared remote control service, but works also with cable"
HOMEPAGE="http://anyremote.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -16,6 +18,12 @@ RDEPEND="bluetooth? ( net-wireless/bluez-libs net-wireless/bluez-utils )
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/btio.patch"
+}
+
src_compile() {
econf $(use_enable bluetooth bluez)
emake || die "emake failed"
diff --git a/net-misc/anyremote/files/btio.patch b/net-misc/anyremote/files/btio.patch
new file mode 100644
index 000000000..eb4034b02
--- /dev/null
+++ b/net-misc/anyremote/files/btio.patch
@@ -0,0 +1,38 @@
+--- src/btio.c 2008-08-06 23:54:18.000000000 +0300
++++ src/btio.c 2008-09-11 21:07:22.000000000 +0300
+@@ -18,7 +18,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ //
+-
++
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -488,6 +488,8 @@
+ // Support SDP
+ //
+
++#ifdef USE_BT
++
+ #include <bluetooth/sdp.h>
+ #include <bluetooth/sdp_lib.h>
+
+@@ -570,14 +572,17 @@
+ sdp_list_free( svc_class_list, 0 );
+ sdp_list_free( profile_list, 0 );
+ }
++#endif
+
+ void sdpDeregister()
+ {
++ #ifdef USE_BT
+ if (session != NULL) {
+ sdp_record_unregister(session, record);
+ session = NULL;
+ //sdp_record_free(record);
+ }
++ #endif
+ }
+
+ //