summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2008-10-21 08:57:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2008-10-21 08:57:56 +0000
commitd1bfb4fd93060230a4f11497628711e4fe95ea75 (patch)
tree2d1930f79648103a42a37ac375bd4a5fe0455cd9 /net-misc/kanyremote/kanyremote-5.4.ebuild
parentnet-p2p/buildtorrent: Tested on amd64 (diff)
downloadsunrise-d1bfb4fd93060230a4f11497628711e4fe95ea75.tar.gz
sunrise-d1bfb4fd93060230a4f11497628711e4fe95ea75.tar.bz2
sunrise-d1bfb4fd93060230a4f11497628711e4fe95ea75.zip
net-misc/kanyremote: Version bump
svn path=/sunrise/; revision=7242
Diffstat (limited to 'net-misc/kanyremote/kanyremote-5.4.ebuild')
-rw-r--r--net-misc/kanyremote/kanyremote-5.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/kanyremote/kanyremote-5.4.ebuild b/net-misc/kanyremote/kanyremote-5.4.ebuild
new file mode 100644
index 000000000..821799b5b
--- /dev/null
+++ b/net-misc/kanyremote/kanyremote-5.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=" >=net-misc/anyremote-4.4
+ >=dev-python/PyQt-3.17
+ >=dev-python/pykde-3.16"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ make_desktop_entry ${PN} ${PN} ${PN}.png "Network;RemoteAccess"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if ! built_with_use net-misc/anyremote bluetooth ; then
+ echo
+ ewarn "If you want to use bluetooth with kanyremote, you need to "
+ ewarn "compile net-misc/anyremote with bluetooth use flag."
+ echo
+ fi
+}
+