summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2008-12-06 09:04:47 +0000
committerJustin Lecher <jlec@gentoo.org>2008-12-06 09:04:47 +0000
commit93cbb9a4b67d93466568f3e24248162ca48d2a6a (patch)
tree779a45e912781e4dc7a2d5353011aa9bc48abe79 /net-misc/lanmap/lanmap-81-r2.ebuild
parentapp-text/cuneiform: Manifest fixed. (diff)
downloadsunrise-93cbb9a4b67d93466568f3e24248162ca48d2a6a.tar.gz
sunrise-93cbb9a4b67d93466568f3e24248162ca48d2a6a.tar.bz2
sunrise-93cbb9a4b67d93466568f3e24248162ca48d2a6a.zip
net-misc/lanmap: New Ebuild for bug 249631 - Checking in at sunrise
svn path=/sunrise/; revision=7456
Diffstat (limited to 'net-misc/lanmap/lanmap-81-r2.ebuild')
-rw-r--r--net-misc/lanmap/lanmap-81-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/lanmap/lanmap-81-r2.ebuild b/net-misc/lanmap/lanmap-81-r2.ebuild
new file mode 100644
index 000000000..686bf143a
--- /dev/null
+++ b/net-misc/lanmap/lanmap-81-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="lanmap sits quietly on a network and builds a picture of what it sees"
+HOMEPAGE="http://www.parseerror.com/lanmap"
+SRC_URI="http://www.parseerror.com/${PN}/rev/${PN}-2006-03-07-rev${PV}.zip"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND="net-libs/libpcap
+ media-gfx/graphviz[png]"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ chmod +x configure
+ epatch "${FILESDIR}"/makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake prefix="${D}"/usr install || die
+ dodoc {README,TODO}.txt || die
+}