summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-29 09:19:49 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-29 09:19:49 +0000
commit2272f5171fb5a1c8bc962d320b17fb7e3449fa39 (patch)
tree1dbd42b7b4992d175f12e8708368fb39709d4fad /net-news
parentsci-mathematics/pyquante: Corrected for multiple PyABI installation, added ~a... (diff)
downloadsunrise-2272f5171fb5a1c8bc962d320b17fb7e3449fa39.tar.gz
sunrise-2272f5171fb5a1c8bc962d320b17fb7e3449fa39.tar.bz2
sunrise-2272f5171fb5a1c8bc962d320b17fb7e3449fa39.zip
net-news/rss-notify: Corrected for multiple PyABI installation
svn path=/sunrise/; revision=11921
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rss-notify/ChangeLog5
-rw-r--r--net-news/rss-notify/Manifest4
-rw-r--r--net-news/rss-notify/rss-notify-0.4.ebuild13
3 files changed, 17 insertions, 5 deletions
diff --git a/net-news/rss-notify/ChangeLog b/net-news/rss-notify/ChangeLog
index 8019480ce..688bcb186 100644
--- a/net-news/rss-notify/ChangeLog
+++ b/net-news/rss-notify/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for net-news/rss-notify
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Apr 2011; Justin Lecher <jlec@gentoo.org> rss-notify-0.4.ebuild:
+ Corrected for multiple PyABI installation
+
27 Sep 2009; Alexander van der Mey (alexandervdm)
<alexvandermey@gmail.com> +rss-notify-0.4.ebuild, +metadata.xml:
New Ebuild for bug #286647
diff --git a/net-news/rss-notify/Manifest b/net-news/rss-notify/Manifest
index dc3cf3e8e..c76d66eaf 100644
--- a/net-news/rss-notify/Manifest
+++ b/net-news/rss-notify/Manifest
@@ -1,4 +1,4 @@
DIST rss-notify_0.4-0ubuntu0~ppa1~jaunty.tar.gz 49971 RMD160 5033a4786ea3e42716f30fe3d845581de269df4e SHA1 531deceb28e634b7d7290fd1ecec4d870996a174 SHA256 b116e50f605d4eeddadfcf0f5273b2ba580c9d63da3fd378ab96f32f4cc8f8c8
-EBUILD rss-notify-0.4.ebuild 506 RMD160 daf3ad9ddc6691586ba0654b6c3a707fa15b6943 SHA1 873034eb40a22b0a592abd4b0b8e37db28af2b4c SHA256 192f61dd929675ac7280ae10af9d423048617f14562607b5faf4c6c4a867380a
-MISC ChangeLog 269 RMD160 69818d069e5a66594c50cf7428e816d01ecd326f SHA1 0a497ad588911bf47a6fea81478982ed71200607 SHA256 29e1f7d5dd5dfabe6c977e69a604313f1554544ef46daf3e66c5344c4e6caedb
+EBUILD rss-notify-0.4.ebuild 616 RMD160 b1acf3b6f664f81b5feb24a5b880452ac1a37cbb SHA1 5097a37e82df1bf66533c3d15acc0811c01dbbe8 SHA256 5fc55911408095e45aac93a4b72e3d31c39c07efbcc7b0e9d1de18e77ca54c93
+MISC ChangeLog 384 RMD160 dbded32612695c915fcb2e878a9fdf6479ff3caa SHA1 461bfb95501c320dc6021f4f3a63554cf5a07543 SHA256 b9789c4cfa48776b60a8d4866f2a01b67fc63fec88e92456ad97aea05a734397
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/net-news/rss-notify/rss-notify-0.4.ebuild b/net-news/rss-notify/rss-notify-0.4.ebuild
index 59efc8da6..bd21e3ee5 100644
--- a/net-news/rss-notify/rss-notify-0.4.ebuild
+++ b/net-news/rss-notify/rss-notify-0.4.ebuild
@@ -1,7 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
DESCRIPTION="RSS reader in the style of notify-osd"
@@ -13,7 +19,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-python/feedparser
+RDEPEND="
+ dev-python/feedparser
>=dev-python/gconf-python-2.22.3
>=dev-python/imaging-1.1.6
dev-python/notify-python"
+
+PYTHON_MODNAME="${PN/-/_}"