summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjakobdettner <gentoo@dettner.de>2006-12-07 19:57:26 +0000
committerjakobdettner <gentoo@dettner.de>2006-12-07 19:57:26 +0000
commitcc8153521f15188de163815ef33026cb3eece8a2 (patch)
treec98c1b4e00c6b8b38170933b73bd74cda20f36d8 /net-print/cupsddk/cupsddk-1.1.0_p20061207.ebuild
parentx11-misc/dmenu: Version bump (diff)
downloadsunrise-cc8153521f15188de163815ef33026cb3eece8a2.tar.gz
sunrise-cc8153521f15188de163815ef33026cb3eece8a2.tar.bz2
sunrise-cc8153521f15188de163815ef33026cb3eece8a2.zip
net-print/cupsddk: New Ebuild for bug 157300 thanks.
svn path=/sunrise/; revision=2152
Diffstat (limited to 'net-print/cupsddk/cupsddk-1.1.0_p20061207.ebuild')
-rw-r--r--net-print/cupsddk/cupsddk-1.1.0_p20061207.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-print/cupsddk/cupsddk-1.1.0_p20061207.ebuild b/net-print/cupsddk/cupsddk-1.1.0_p20061207.ebuild
new file mode 100644
index 000000000..46ff72e08
--- /dev/null
+++ b/net-print/cupsddk/cupsddk-1.1.0_p20061207.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Provides a suite of standard drivers, a PPD file compiler, and other utilities that can be used to develop printer drivers for CUPS and other printing environments."
+HOMEPAGE="http://www.cups.org/ddk/index.php"
+SRC_URI="http://jdettner.free.fr/gentoo/cupsddk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ econf BUILDROOT="${D}" || die "econf failed"
+ emake BUILDROOT="${D}" || die "emake failed"
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install || die "emake install failed"
+}
+