summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorazazello <gentoo@horizon.ath.cx>2007-04-30 16:38:08 +0000
committerazazello <gentoo@horizon.ath.cx>2007-04-30 16:38:08 +0000
commitf76b434277261dda02e3cda2521cd96ddda5cbc9 (patch)
treeb0e5d0e4cd6f110e315c4823e4f3406390e479e5 /sci-biology/blat/blat-34.ebuild
parentnet-analyzer/daemonlogger: new ebuild for bug 174128 thanks to Jukka Ruohonen (diff)
downloadsunrise-f76b434277261dda02e3cda2521cd96ddda5cbc9.tar.gz
sunrise-f76b434277261dda02e3cda2521cd96ddda5cbc9.tar.bz2
sunrise-f76b434277261dda02e3cda2521cd96ddda5cbc9.zip
sci-biology/blat: version bump!
svn path=/sunrise/; revision=3561
Diffstat (limited to 'sci-biology/blat/blat-34.ebuild')
-rw-r--r--sci-biology/blat/blat-34.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/blat/blat-34.ebuild b/sci-biology/blat/blat-34.ebuild
new file mode 100644
index 000000000..665fdf9fe
--- /dev/null
+++ b/sci-biology/blat/blat-34.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="The BLAST-Like Alignment Tool, a fast genomic sequence aligner"
+LICENSE="blat"
+HOMEPAGE="http://www.cse.ucsc.edu/~kent/"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+SRC_URI="http://www.soe.ucsc.edu/~kent/src/${PN}Src${PV}.zip"
+S="${WORKDIR}/${PN}Src"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ MACHTYPE=$(tc-arch)
+ if [[ $MACHTYPE == "x86" ]]; then MACHTYPE="i386"; fi
+ sed -i 's/-Werror//; s/CFLAGS=//;' "${S}/inc/common.mk"
+ sed -i 's/\(${STRIP} \)/#\1/' "${S}"/{*/makefile,utils/*/makefile,*/*.mk}
+ mkdir -p "${S}/bin/${MACHTYPE}"
+ emake MACHTYPE="${MACHTYPE}" HOME="${S}" || die "emake failed"
+}
+
+src_install() {
+ MACHTYPE=$(tc-arch)
+ if [[ $MACHTYPE == "x86" ]]; then MACHTYPE="i386"; fi
+ dobin "${S}/bin/${MACHTYPE}/"*
+}