summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-29 08:54:24 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-29 08:54:24 +0000
commit732b8cc896de442e977f7fc2a8cbfa8b9614fa57 (patch)
tree113696350699238132ac8776ca94784fbc175906 /sci-mathematics/pyquante/pyquante-1.5.1.ebuild
parentwww-client/ttb: Corrected for multiple PyABI installation, added ~amd64 (diff)
downloadsunrise-732b8cc896de442e977f7fc2a8cbfa8b9614fa57.tar.gz
sunrise-732b8cc896de442e977f7fc2a8cbfa8b9614fa57.tar.bz2
sunrise-732b8cc896de442e977f7fc2a8cbfa8b9614fa57.zip
sci-mathematics/pyquante: Corrected for multiple PyABI installation, added ~amd64
svn path=/sunrise/; revision=11920
Diffstat (limited to 'sci-mathematics/pyquante/pyquante-1.5.1.ebuild')
-rw-r--r--sci-mathematics/pyquante/pyquante-1.5.1.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/sci-mathematics/pyquante/pyquante-1.5.1.ebuild b/sci-mathematics/pyquante/pyquante-1.5.1.ebuild
index 31efe7897..36fc33da2 100644
--- a/sci-mathematics/pyquante/pyquante-1.5.1.ebuild
+++ b/sci-mathematics/pyquante/pyquante-1.5.1.ebuild
@@ -1,22 +1,27 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
MY_PN="PyQuante"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="a quantum chemistry package written in Python."
+DESCRIPTION="Quantum chemistry package written in Python"
HOMEPAGE="http://pyquante.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"