summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-04-30 13:04:27 +0000
committerMichał Górny <mgorny@gentoo.org>2010-04-30 13:04:27 +0000
commit5e4f5b4d43468b7cfda721da4df6d02aea560ba8 (patch)
tree06f20856fa232f4dfd21c86258c71301bdba3807 /sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild
parentNew category: sci-physics. (diff)
downloadsunrise-5e4f5b4d43468b7cfda721da4df6d02aea560ba8.tar.gz
sunrise-5e4f5b4d43468b7cfda721da4df6d02aea560ba8.tar.bz2
sunrise-5e4f5b4d43468b7cfda721da4df6d02aea560ba8.zip
sci-physics/KRT: New ebuild for bug #317363.
svn path=/sunrise/; revision=10512
Diffstat (limited to 'sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild')
-rw-r--r--sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild b/sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild
new file mode 100644
index 000000000..ebf784656
--- /dev/null
+++ b/sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+inherit cmake-utils eutils versionator
+
+MY_P=${PN}-$(replace_version_separator 3 -)
+DESCRIPTION="A lattice solver"
+HOMEPAGE="http://czlug.icis.pcz.pl/~zygmunt/programs/KRT/"
+SRC_URI="http://czlug.icis.pcz.pl/~zygmunt/public/programs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ _check_build_dir
+ dobin "${CMAKE_BUILD_DIR}"/${PN} || die
+
+ if use examples; then
+ docinto examples
+ dodoc example/* || die
+ fi
+
+ doicon "${FILESDIR}"/${PN}.xpm || die
+ make_desktop_entry ${PN} ${PN} ${PN} 'Education;Science;Engineering'
+}