summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Tarkovsky <alextarkovsky@gmail.org>2006-07-03 19:44:32 +0000
committerAlex Tarkovsky <alextarkovsky@gmail.org>2006-07-03 19:44:32 +0000
commit3c6dd401f32dbc1e9c1df04bde7df95a43e49159 (patch)
treeae441bf6398fffb653f3a5d043001940266c811a /scripts/sunrise-commit
parentscripts/sunrise-commit: Exit with informative message if svn update results i... (diff)
downloadsunrise-3c6dd401f32dbc1e9c1df04bde7df95a43e49159.tar.gz
sunrise-3c6dd401f32dbc1e9c1df04bde7df95a43e49159.tar.bz2
sunrise-3c6dd401f32dbc1e9c1df04bde7df95a43e49159.zip
scripts/sunrise-commit: Prevent duplicate and conflicting ChangeLog modifications
svn path=/sunrise/; revision=457
Diffstat (limited to 'scripts/sunrise-commit')
-rwxr-xr-xscripts/sunrise-commit12
1 files changed, 10 insertions, 2 deletions
diff --git a/scripts/sunrise-commit b/scripts/sunrise-commit
index 0c0fc158c..e8f31d569 100755
--- a/scripts/sunrise-commit
+++ b/scripts/sunrise-commit
@@ -25,6 +25,14 @@ opt_verbose=0
changelog_append() {
if [[ "$opt_changelog" == "1" ]] ; then
+ if [[ "$(svn status)" =~ 'ChangeLog' ]] ; then
+ echo "!!! Error: Only one ChangeLog entry should be made per commit, and you have"
+ echo "!!! already modified your ChangeLog locally since your last commit. To keep the"
+ echo "!!! pre-existing modifications please run sunrise-commit again without the -c"
+ echo "!!! option. To discard the pre-existing modifications run:"
+ echo "!!! svn revert ChangeLog"
+ exit 1
+ fi
ebegin "Appending/creating ChangeLog"
echangelog "$*"
eend $?
@@ -41,10 +49,10 @@ create_digests() {
fi
}
+
repoman_check() {
if [[ "$opt_norepoman" == "0" ]] ; then
- commit_status="$(echo `svn status`)"
- if [[ "$commit_status" =~ '\.ebuild' ]] ; then
+ if [[ "$(svn status)" =~ '\.ebuild' ]] ; then
ebegin "Running repoman"
export PORTDIR_OVERLAY="$(dirname $(dirname $(pwd)))"
repoman