summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosu López Fernández <zamorate@zamorate.net>2006-07-06 17:23:10 +0000
committerJosu López Fernández <zamorate@zamorate.net>2006-07-06 17:23:10 +0000
commitfda0efaf47a9031e9d5c4da6a4ea444f372b3ac8 (patch)
tree55ed92e5df8f74560b4c222670c2a96319653bb2 /sys-apps/remendeko/remendeko-0.3.0.ebuild
parentsys-apps/remendeko: Respect correct CC. Added ~amd64 and ~ppc keywords (diff)
downloadsunrise-fda0efaf47a9031e9d5c4da6a4ea444f372b3ac8.tar.gz
sunrise-fda0efaf47a9031e9d5c4da6a4ea444f372b3ac8.tar.bz2
sunrise-fda0efaf47a9031e9d5c4da6a4ea444f372b3ac8.zip
sys-apps/remendeko: Respect correct CC. Added ~amd64 and ~ppc keywords
svn path=/sunrise/; revision=499
Diffstat (limited to 'sys-apps/remendeko/remendeko-0.3.0.ebuild')
-rw-r--r--sys-apps/remendeko/remendeko-0.3.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/remendeko/remendeko-0.3.0.ebuild b/sys-apps/remendeko/remendeko-0.3.0.ebuild
index 07f96da5e..578e40e49 100644
--- a/sys-apps/remendeko/remendeko-0.3.0.ebuild
+++ b/sys-apps/remendeko/remendeko-0.3.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit toolchain-funcs
+
MY_PN="RemenDeKO"
DESCRIPTION="File corruption detection and repair program"
HOMEPAGE="http://rdko.sourceforge.net/"
@@ -9,7 +11,7 @@ SRC_URI="mirror://sourceforge/rdko/${MY_PN}-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gtk"
RESTRICT="strip"
@@ -29,11 +31,14 @@ src_unpack() {
-e '/^CFLAGSGUI/s:-fmessage-length=0 -fexpensive-optimizations -O3:$(CFLAGS):' \
Makefile || die "sed Makefile failed"
}
+
src_compile() {
if use gtk; then
- emake E_CFLAGS="${CFLAGS}" || die "emake failed"
+ emake E_CFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ || die "emake failed"
else
- emake E_CFLAGS="${CFLAGS}" rdko || die "emake failed"
+ emake E_CFLAGS="${CFLAGS}" CC="$(tc-getCC)" rdko \
+ || die "emake failed"
fi
}