summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-05-20 06:54:21 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-05-20 06:54:21 +0000
commitba1df8b2eea7868a3bcaab50d621fbf3927fff27 (patch)
treef53c75eea522515f2191dd33d8c79d3a9bf3eabb /sys-apps
parentmedia-tv/zattoo-bin: added some quotes around variable (diff)
downloadsunrise-ba1df8b2eea7868a3bcaab50d621fbf3927fff27.tar.gz
sunrise-ba1df8b2eea7868a3bcaab50d621fbf3927fff27.tar.bz2
sunrise-ba1df8b2eea7868a3bcaab50d621fbf3927fff27.zip
new ebuild for bug 127010
svn path=/sunrise/; revision=3682
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mlocate/Manifest4
-rw-r--r--sys-apps/mlocate/files/digest-mlocate-0.173
-rw-r--r--sys-apps/mlocate/files/mlocate.cron11
-rw-r--r--sys-apps/mlocate/files/updatedb.conf11
-rw-r--r--sys-apps/mlocate/mlocate-0.17.ebuild54
5 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/mlocate/Manifest b/sys-apps/mlocate/Manifest
new file mode 100644
index 000000000..e2b700be5
--- /dev/null
+++ b/sys-apps/mlocate/Manifest
@@ -0,0 +1,4 @@
+AUX mlocate.cron 152 RMD160 bc5c48ff209516873ac858f1ee9f88b635507fb9 SHA1 3566c291ec0644051029e2c6b75e15957ab1e8a0 SHA256 2d682a0938a7d855b9dfff40c4fa31acd587c298c758be274a761ab9cc0a9e0f
+AUX updatedb.conf 567 RMD160 021353a0cf3c57d904765f96f03148cd5cfbb0c3 SHA1 f64fe505f0300e82b60e9cd721532d62fcaa7b28 SHA256 74fff35f438de2a67798bfeca7c334c8dc42f280cae305f8370724440342be38
+DIST mlocate-0.17.tar.bz2 285610 RMD160 ba8d292d757ed48782760ecfc58d12ea15fb9b05 SHA1 9fe1d51df41043f437850b6ba96df40d5e7525ad SHA256 a7c9c79a39b14f7a122f1b792ab3b26794dd8bd0f87cfe1a1127767ca5479584
+EBUILD mlocate-0.17.ebuild 1237 RMD160 b135ba15d7262bf1628341fb0b376c859d6e80a0 SHA1 ccc1f1c8000bf6be300e5ee598f820f87085d4f7 SHA256 37fe5005341e75cc8a002bc45be2e485389c64228fa92c2ea5e3ddbd8bf32f06
diff --git a/sys-apps/mlocate/files/digest-mlocate-0.17 b/sys-apps/mlocate/files/digest-mlocate-0.17
new file mode 100644
index 000000000..2712bc18e
--- /dev/null
+++ b/sys-apps/mlocate/files/digest-mlocate-0.17
@@ -0,0 +1,3 @@
+MD5 e8fc089a235a4a7bf9bfbc536c17116c mlocate-0.17.tar.bz2 285610
+RMD160 ba8d292d757ed48782760ecfc58d12ea15fb9b05 mlocate-0.17.tar.bz2 285610
+SHA256 a7c9c79a39b14f7a122f1b792ab3b26794dd8bd0f87cfe1a1127767ca5479584 mlocate-0.17.tar.bz2 285610
diff --git a/sys-apps/mlocate/files/mlocate.cron b/sys-apps/mlocate/files/mlocate.cron
new file mode 100644
index 000000000..c7a39c274
--- /dev/null
+++ b/sys-apps/mlocate/files/mlocate.cron
@@ -0,0 +1,11 @@
+#! /bin/sh
+
+if [ -x /usr/bin/updatedb ]
+then
+ if [ -f /etc/updatedb.conf ]
+ then
+ nice /usr/bin/updatedb
+ else
+ nice /usr/bin/updatedb -f proc
+ fi
+fi
diff --git a/sys-apps/mlocate/files/updatedb.conf b/sys-apps/mlocate/files/updatedb.conf
new file mode 100644
index 000000000..c31e1c470
--- /dev/null
+++ b/sys-apps/mlocate/files/updatedb.conf
@@ -0,0 +1,11 @@
+# /etc/updatedb.conf: config file for slocate
+# $Id: updatedb.conf,v 1.19 2005/11/10 02:39:05 vapier Exp $
+
+# This file sets variables that are used by updatedb.
+# For more info, see the updatedb(1) manpage.
+
+# Filesystems that are pruned from updatedb database
+PRUNEFS="afs auto autofs cifs devfs devpts eventpollfs futexfs hugetlbfs iso9660 mqueue ncpfs nfs NFS nfsd nnpfs pipefs proc ramfs rpc_pipefs sfs shfs smbfs sockfs subfs supermount sysfs tmpfs udf usbfs vperfctrfs"
+
+# Paths which are pruned from updatedb database
+PRUNEPATHS="/tmp /var/tmp /root/.ccache"
diff --git a/sys-apps/mlocate/mlocate-0.17.ebuild b/sys-apps/mlocate/mlocate-0.17.ebuild
new file mode 100644
index 000000000..f0b028345
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="http://carolina.mff.cuni.cz/~trmac/blog/mlocate/"
+SRC_URI="http://people.redhat.com/mitr/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/shadow"
+RDEPEND="${DEPEND}
+ !sys-apps/slocate
+ !sys-apps/rlocate"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_compile() {
+ econf || die
+ emake groupname=locate || die "emake failed"
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}/updatedb.conf"
+ fperms 0644 /etc/updatedb.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/mlocate.cron" mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners root:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ chown -R root:locate "${D}/var/lib/mlocate"
+ fperms 0750 /var/lib/mlocate
+
+ touch "${D}/var/lib/mlocate/mlocate.db"
+}
+
+pkg_postinst() {
+ einfo "Note that the /etc/updatedb.conf file is generic"
+ einfo "Please customize it to your system requirements"
+}