summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-01-28 19:54:33 +0000
committerAli Polatel <hawking@gentoo.org>2007-01-28 19:54:33 +0000
commit37fe4da139daa84e4efc11b11cbb7a402cc44917 (patch)
treededcefa2e5b17866cd939e25b6b7ee8b59ea1f83 /sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
parentdev-python/yapps: Added examples use flag (diff)
downloadsunrise-37fe4da139daa84e4efc11b11cbb7a402cc44917.tar.gz
sunrise-37fe4da139daa84e4efc11b11cbb7a402cc44917.tar.bz2
sunrise-37fe4da139daa84e4efc11b11cbb7a402cc44917.zip
sys-auth/pam_sha512: New ebuild for bug 102113 thanks to neuron
svn path=/sunrise/; revision=2862
Diffstat (limited to 'sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild')
-rw-r--r--sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild b/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
new file mode 100644
index 000000000..0a09cbf26
--- /dev/null
+++ b/sys-auth/pam_sha512/pam_sha512-0.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic pam toolchain-funcs
+
+DESCRIPTION="Pam module to allow authentication via sha512 hash'ed passwords."
+HOMEPAGE="http://hollowtube.mine.nu/wiki/index.php?n=Projects.PamSha512"
+SRC_URI="http://hollowtube.mine.nu/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+ app-crypt/hashalot"
+
+src_compile() {
+ append-flags "-fPIC -c -Wall -Wformat-security"
+ emake CC=$(tc-getCC) \
+ LD=$(tc-getLD) \
+ CFLAGS="${CFLAGS}" || die "emake failed"
+ # CFLAGS="${CFLAGS}" is required
+}
+
+src_install() {
+ dopammod pam_sha512.so
+ dodoc README
+ dosbin hashpass
+}