summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-16 13:55:17 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-16 13:55:17 +0000
commite1627e9de0a33a00fe4047fb7f3418ae07731cc9 (patch)
tree61df0d8420e59a49d8e6a3e7d52fbaf616ac5dab /sys-fs/cryptmount/cryptmount-1.1.ebuild
parentx11-misc/kxstitch: New ebuild for my wife, :) and #63847 (diff)
downloadsunrise-e1627e9de0a33a00fe4047fb7f3418ae07731cc9.tar.gz
sunrise-e1627e9de0a33a00fe4047fb7f3418ae07731cc9.tar.bz2
sunrise-e1627e9de0a33a00fe4047fb7f3418ae07731cc9.zip
sys-fs/cryptmount: CONFIG_CHECK and emake install
svn path=/sunrise/; revision=1260
Diffstat (limited to 'sys-fs/cryptmount/cryptmount-1.1.ebuild')
-rw-r--r--sys-fs/cryptmount/cryptmount-1.1.ebuild36
1 files changed, 9 insertions, 27 deletions
diff --git a/sys-fs/cryptmount/cryptmount-1.1.ebuild b/sys-fs/cryptmount/cryptmount-1.1.ebuild
index 8e1f5dd6d..e4f9cef97 100644
--- a/sys-fs/cryptmount/cryptmount-1.1.ebuild
+++ b/sys-fs/cryptmount/cryptmount-1.1.ebuild
@@ -18,30 +18,12 @@ DEPEND="sys-fs/device-mapper
ssl? ( dev-libs/openssl )
nls? ( sys-devel/gettext )"
RDEPEND="${DEPEND}"
-
-dm-crypt_check() {
- ebegin "Checking for Device mapper support (BLK_DEV_DM)"
- linux_chkconfig_present BLK_DEV_DM
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- ewarn "Cryptmount requires Device mapper support!"
- ewarn "Please enable Device mapper support in your kernel config, found at:"
- ewarn "(for 2.6 kernels)"
- ewarn
- ewarn " Device Drivers"
- ewarn " Multi-Device Support"
- ewarn " <*> Device mapper support"
- ewarn
- ewarn "and recompile your kernel if you want this package to work."
- epause 10
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- dm-crypt_check
-}
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="Please enable Device mapper support in your kernel config
+ -> Device Drivers
+ -> Multi-device support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM) (MD)
+ <M> Device mapper support"
src_compile() {
# recommended for setXid, dynamically linked biraries
@@ -52,12 +34,12 @@ src_compile() {
--with-libgcrypt \
$(use_enable nls) \
$(use_with ssl openssl) \
- || die "Configuration failed"
+ || die "econf failed"
- emake || die "Compilation failed"
+ emake || die "emake failed"
}
src_install() {
- make install DESTDIR="${D}" || die "Installation failed"
+ emake install DESTDIR="${D}" || die "emake install failed"
dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README RELNOTES ToDo
}