summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2007-08-25 21:19:30 +0000
committerFederico Ferri <mescalinum@gentoo.org>2007-08-25 21:19:30 +0000
commit73a162573697ad261157eacab8ca3843b5a79ff7 (patch)
tree9842e25a47a7b18f7db092df64b3a3bc12074f7a /sys-process/daemon/daemon-0.6.3.ebuild
parentremoved rsstool from sunrise as it is now in portage (diff)
downloadsunrise-73a162573697ad261157eacab8ca3843b5a79ff7.tar.gz
sunrise-73a162573697ad261157eacab8ca3843b5a79ff7.tar.bz2
sunrise-73a162573697ad261157eacab8ca3843b5a79ff7.zip
sys-process/daemon: New Ebuild for bug 91030
svn path=/sunrise/; revision=4501
Diffstat (limited to 'sys-process/daemon/daemon-0.6.3.ebuild')
-rw-r--r--sys-process/daemon/daemon-0.6.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-process/daemon/daemon-0.6.3.ebuild b/sys-process/daemon/daemon-0.6.3.ebuild
new file mode 100644
index 000000000..47718756e
--- /dev/null
+++ b/sys-process/daemon/daemon-0.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Daemon turns other process into daemons, respawning automatically"
+HOMEPAGE="http://www.libslack.org/daemon/"
+SRC_URI="http://libslack.org/daemon/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/strip/d' rules.mk
+}
+
+src_compile() {
+ ./config
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ CCFLAGS="${CFLAGS}" PREFIX="/usr"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc README
+}