summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlebarjack <francois.perichon@univ-lille2.fr>2009-07-01 08:56:41 +0000
committerlebarjack <francois.perichon@univ-lille2.fr>2009-07-01 08:56:41 +0000
commit9dcc41ce6fe3abb6ee9bfd0432b3515ff3a8a2a2 (patch)
treeed7ecb5df1f763c8e21f219e87ae06c9240b8143 /www-apps/davical/davical-0.9.7.ebuild
parentdev-php/awl: New version for the awl library (diff)
downloadsunrise-9dcc41ce6fe3abb6ee9bfd0432b3515ff3a8a2a2.tar.gz
sunrise-9dcc41ce6fe3abb6ee9bfd0432b3515ff3a8a2a2.tar.bz2
sunrise-9dcc41ce6fe3abb6ee9bfd0432b3515ff3a8a2a2.zip
www-apps/davical: New version for davical
svn path=/sunrise/; revision=8722
Diffstat (limited to 'www-apps/davical/davical-0.9.7.ebuild')
-rw-r--r--www-apps/davical/davical-0.9.7.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/davical/davical-0.9.7.ebuild b/www-apps/davical/davical-0.9.7.ebuild
new file mode 100644
index 000000000..0c008b0c5
--- /dev/null
+++ b/www-apps/davical/davical-0.9.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit webapp depend.php
+
+DESCRIPTION="A CalDAV and iCal server"
+HOMEPAGE="http://davical.org/"
+SRC_URI="http://debian.mcmillan.net.nz/debian/dists/lenny/awm/source/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc vhosts"
+
+DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="www-servers/apache
+ dev-lang/php[pcre,postgres,xml]
+ app-admin/pwgen
+ >=dev-php/awl-0.37
+ dev-perl/yaml
+ dev-perl/DBI
+ dev-perl/DBD-Pg"
+
+need_php5
+need_httpd
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini"
+ eend $? || die "Documentation failed to build"
+ fi
+ emake inc/always.php || die "emake failed"
+ scripts/po/rebuild-translations.sh
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="INSTALL README debian/README.Debian \
+ testing/README.regression_tests \
+ TODO debian/changelog"
+ dodoc-php ${docs} || die "dodoc failed"
+
+ einfo "Installing main files"
+ local dirs="htdocs inc locale"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r ${dirs} || die "doins failed"
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/* || die "doins failed"
+
+ if use doc ; then
+ einfo "Installing documentation"
+ dohtml -r "docs/api/" || die "dohtml failed"
+ dohtml -r "docs/website/" || die "dohtml failed"
+ fi
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}/rscds.conf" calendar.example.com-conf.php \
+ || die "newins failed"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-rscds-database"
+
+}