summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Nagel (padde) <mail@patrick-nagel.net>2010-03-24 07:07:21 +0000
committerPatrick Nagel (padde) <mail@patrick-nagel.net>2010-03-24 07:07:21 +0000
commitc55d46e2a35c817d231e815c0f308660a9a20fb5 (patch)
tree93cadd7fbf2ef17076a1cf86e5f6642e517c2ac2 /www-apps/tt-rss/tt-rss-1.4.1.ebuild
parentdev-db/pgmemcache: Use proper depend (suggested by upstream) (diff)
downloadsunrise-c55d46e2a35c817d231e815c0f308660a9a20fb5.tar.gz
sunrise-c55d46e2a35c817d231e815c0f308660a9a20fb5.tar.bz2
sunrise-c55d46e2a35c817d231e815c0f308660a9a20fb5.zip
www-apps/tt-rss: Version bump for tt-rss and removed mysqli USE flag, thanks to Necoro
svn path=/sunrise/; revision=10338
Diffstat (limited to 'www-apps/tt-rss/tt-rss-1.4.1.ebuild')
-rw-r--r--www-apps/tt-rss/tt-rss-1.4.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-apps/tt-rss/tt-rss-1.4.1.ebuild b/www-apps/tt-rss/tt-rss-1.4.1.ebuild
new file mode 100644
index 000000000..6df41b4fe
--- /dev/null
+++ b/www-apps/tt-rss/tt-rss-1.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit webapp depend.php depend.apache
+
+DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
+HOMEPAGE="http://tt-rss.org/"
+SRC_URI="http://tt-rss.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE="mysql postgres"
+
+DEPEND="dev-lang/php[mysql?,postgres?]"
+RDEPEND="${DEPEND}"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_prepare() {
+ # Customize config.php so that the right 'DB_TYPE' is already set (according to the USE flag)
+ einfo "Customizing config.php..."
+ mv config.php{-dist,} || die "Could not rename config.php-dist to config.php."
+ if use mysql && ! use postgres; then
+ sed -e "/define('DB_TYPE',/{s:pgsql:mysql:}" -i config.php || die "sed failed"
+ fi
+ sed -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" -i config.php \
+ || die "sed failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "/${MY_HTDOCSDIR}"
+ doins -r * || die "Could not copy the files to ${MY_HTDOCSDIR}."
+ keepdir "/${MY_HTDOCSDIR}"/icons
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/icons
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}