summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Carnecky (wereHamster) <tom@dbservice.com>2007-06-07 19:20:27 +0000
committerTomas Carnecky (wereHamster) <tom@dbservice.com>2007-06-07 19:20:27 +0000
commit197cb737e9d91ebc92bf39fbee4623feabb75527 (patch)
tree3f28f3d4b70e145b90f675cccbd78b402485d7da /x11-apps/yukon/yukon-1.0.97.ebuild
parentNew USE flags 'doom1','doom2','heretic','hexen','plutonia' and 'tnt' for game... (diff)
downloadsunrise-197cb737e9d91ebc92bf39fbee4623feabb75527.tar.gz
sunrise-197cb737e9d91ebc92bf39fbee4623feabb75527.tar.bz2
sunrise-197cb737e9d91ebc92bf39fbee4623feabb75527.zip
x11-apps/yukon: Initial import (bug #181216)
svn path=/sunrise/; revision=3828
Diffstat (limited to 'x11-apps/yukon/yukon-1.0.97.ebuild')
-rw-r--r--x11-apps/yukon/yukon-1.0.97.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-apps/yukon/yukon-1.0.97.ebuild b/x11-apps/yukon/yukon-1.0.97.ebuild
new file mode 100644
index 000000000..14b1625b2
--- /dev/null
+++ b/x11-apps/yukon/yukon-1.0.97.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator toolchain-funcs multilib
+
+RESTRICT="multilib-pkg-force"
+
+DESCRIPTION="OpenGL video capturing framework"
+HOMEPAGE="http://neopsis.com/projects/yukon"
+
+MY_PV="$(replace_version_separator 2 '-')"
+SRC_URI="http://dbservice.com/ftpdir/tom/yukon/trunk/yukon-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/seom"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ for ABI in $(get_install_abis); do
+ unpack ${A}
+ mv "${PN}-${MY_PV}" "${ABI}"
+ done
+}
+
+src_compile() {
+ for ABI in $(get_install_abis); do
+ cd "${WORKDIR}/${ABI}"
+
+ econf --libdir="$(get_abi_LIBDIR ${ABI})" || die "econf failed"
+ emake CC="$(tc-getCC) $(get_abi_CFLAGS ${ABI})" || die "emake failed"
+ done
+}
+
+src_install() {
+ dodir /etc/yukon/system
+
+ for ABI in $(get_install_abis); do
+ cd "${WORKDIR}/${ABI}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cp sysconf "${D}/etc/yukon/system/${ABI}"
+ done
+}
+