summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2009-12-04 12:56:17 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2009-12-04 12:56:17 +0000
commit978b66db73218fd5354e8a315e243c174e69404e (patch)
treec9e42d4b38d524e5920d875426da82b39a4cb2e0 /x11-base/nouveau-drm/nouveau-drm-20091204.ebuild
parentx11-terms/terminator: version bump (diff)
downloadsunrise-978b66db73218fd5354e8a315e243c174e69404e.tar.gz
sunrise-978b66db73218fd5354e8a315e243c174e69404e.tar.bz2
sunrise-978b66db73218fd5354e8a315e243c174e69404e.zip
x11-base/nouveau-drm: new snapshot
svn path=/sunrise/; revision=9644
Diffstat (limited to 'x11-base/nouveau-drm/nouveau-drm-20091204.ebuild')
-rw-r--r--x11-base/nouveau-drm/nouveau-drm-20091204.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-base/nouveau-drm/nouveau-drm-20091204.ebuild b/x11-base/nouveau-drm/nouveau-drm-20091204.ebuild
new file mode 100644
index 000000000..1cb46570b
--- /dev/null
+++ b/x11-base/nouveau-drm/nouveau-drm-20091204.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Nouveau DRM Kernel Modules for X11"
+HOMEPAGE="http://nouveau.freedesktop.org/"
+SRC_URI="http://omploader.org/vMms3bw/${P}.tar.gz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND="virtual/linux-sources
+ !x11-base/x11-drm"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/master
+
+CONFIG_CHECK="~BACKLIGHT_CLASS_DEVICE ~DEBUG_FS !DRM ~FB_CFB_FILLRECT ~FB_CFB_COPYAREA ~FB_CFB_IMAGEBLIT ~!FB_VESA ~!FB_UVESA ~FRAMEBUFFER_CONSOLE"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ if kernel_is lt 2 6 31; then
+ eerror "You need at least kernel 2.6.31"
+ die "Kernel too old"
+ fi
+}
+
+src_prepare() {
+ if kernel_is ge 2 6 32; then
+ epatch ${FILESDIR}/${P}-nodename_to_devnode.patch # bug 295633
+ fi
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake LINUXDIR="${KERNEL_DIR}" NOUVEAUROOTDIR="${PWD}" -f "${FILESDIR}"/${P}-Makefile || die "Compiling kernel modules failed"
+}
+
+src_install() {
+ insinto "/lib/modules/${KV_FULL}/${PN}"
+ doins drivers/gpu/drm/{*/,}*.ko || die "doins failed"
+}