summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2008-04-29 09:38:40 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2008-04-29 09:38:40 +0000
commit81172882c856ab6397c838c7436bb2eb03b7647c (patch)
tree7bfd7f018e99a2a499ca99a9d46847f49a017474 /x11-libs/hippo-canvas/hippo-canvas-0.2.31.ebuild
parentmedia-libs/exempi: Version bump. (diff)
downloadsunrise-81172882c856ab6397c838c7436bb2eb03b7647c.tar.gz
sunrise-81172882c856ab6397c838c7436bb2eb03b7647c.tar.bz2
sunrise-81172882c856ab6397c838c7436bb2eb03b7647c.zip
x11-libs/hippo-canvas: Version bump.
svn path=/sunrise/; revision=6121
Diffstat (limited to 'x11-libs/hippo-canvas/hippo-canvas-0.2.31.ebuild')
-rw-r--r--x11-libs/hippo-canvas/hippo-canvas-0.2.31.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/hippo-canvas/hippo-canvas-0.2.31.ebuild b/x11-libs/hippo-canvas/hippo-canvas-0.2.31.ebuild
new file mode 100644
index 000000000..92f654f6c
--- /dev/null
+++ b/x11-libs/hippo-canvas/hippo-canvas-0.2.31.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+GCONF_DEBUG="no"
+inherit gnome2
+
+DESCRIPTION="A canvas library based on GTK+-2, Cairo, and Pango"
+HOMEPAGE="http://developer.mugshot.org/wiki/Hippo_Canvas"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc python"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/libcroco-0.6
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.14
+ python? ( dev-lang/python
+ dev-python/pycairo
+ dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.6 )"
+
+DOCS="AUTHORS README TODO"
+
+pkg_setup() {
+ G2CONF="$(use_enable python)"
+}