summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-01-25 14:54:02 +0000
committerJakub Moc <jakub@gentoo.org>2008-01-25 14:54:02 +0000
commit92371f03425132f2ef58cffbd4b309916d22e6ac (patch)
treed2146a1bb888b6cf09cb59301aa54dd7c78686cf /x11-libs/seom/seom-1.0.192.ebuild
parentnet-p2p/freenet/freenet-0.7.1103.ebuild: New upstream release (diff)
downloadsunrise-92371f03425132f2ef58cffbd4b309916d22e6ac.tar.gz
sunrise-92371f03425132f2ef58cffbd4b309916d22e6ac.tar.bz2
sunrise-92371f03425132f2ef58cffbd4b309916d22e6ac.zip
x11-libs/seom: Version bump and nuke undownloadable version
svn path=/sunrise/; revision=5508
Diffstat (limited to 'x11-libs/seom/seom-1.0.192.ebuild')
-rw-r--r--x11-libs/seom/seom-1.0.192.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/seom/seom-1.0.192.ebuild b/x11-libs/seom/seom-1.0.192.ebuild
new file mode 100644
index 000000000..fce7a45df
--- /dev/null
+++ b/x11-libs/seom/seom-1.0.192.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator toolchain-funcs multilib
+
+EMULTILIB_PKG="true"
+
+DESCRIPTION="OpenGL video capturing library"
+HOMEPAGE="http://neopsis.com/projects/seom"
+
+SRC_URI="http://dbservice.com/ftpdir/tom/seom/trunk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-lang/yasm-0.6.0"
+RDEPEND=""
+
+src_unpack() {
+ for ABI in $(get_install_abis); do
+ unpack ${A}
+ mv "${P}" "${ABI}"
+ done
+}
+
+src_compile() {
+ for ABI in $(get_install_abis); do
+ cd "${WORKDIR}/${ABI}"
+
+ econf --prefix="/usr" || die "econf failed"
+ emake CC="$(tc-getCC)" $(get_abi_CFLAGS ${ABI}) || die "emake failed"
+ done
+}
+
+src_install() {
+ for ABI in $(get_install_abis); do
+ cd "${WORKDIR}/${ABI}"
+ emake DESTDIR="${D}" LIBDIR="$(get_abi_LIBDIR ${ABI})" install || die "emake install failed"
+ done
+}