summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-06-04 08:09:16 +0000
committerMichał Górny <mgorny@gentoo.org>2010-06-04 08:09:16 +0000
commitf862af1fbb9344b36db0b1fb7fd7136942b755c7 (patch)
treec9f2d3ba60683c12f6e97066f724d2716ff6d05c /x11-misc/sw-notify-send
parentapp-arch/zpaq-extras: Use emake to compile executables, explicitly specify th... (diff)
downloadsunrise-f862af1fbb9344b36db0b1fb7fd7136942b755c7.tar.gz
sunrise-f862af1fbb9344b36db0b1fb7fd7136942b755c7.tar.bz2
sunrise-f862af1fbb9344b36db0b1fb7fd7136942b755c7.zip
x11-misc/sw-notify-send: Use emake to compile the executable.
svn path=/sunrise/; revision=10643
Diffstat (limited to 'x11-misc/sw-notify-send')
-rw-r--r--x11-misc/sw-notify-send/ChangeLog4
-rw-r--r--x11-misc/sw-notify-send/Manifest4
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-0.1.ebuild5
3 files changed, 9 insertions, 4 deletions
diff --git a/x11-misc/sw-notify-send/ChangeLog b/x11-misc/sw-notify-send/ChangeLog
index 9d1fc095d..69423b60c 100644
--- a/x11-misc/sw-notify-send/ChangeLog
+++ b/x11-misc/sw-notify-send/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Jun 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
+ sw-notify-send-0.1.ebuild:
+ Use emake to compile the executable.
+
15 May 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
sw-notify-send-0.1.ebuild:
Drop unnecessary libnotify RDEPEND.
diff --git a/x11-misc/sw-notify-send/Manifest b/x11-misc/sw-notify-send/Manifest
index aaf3b2ced..610fe514a 100644
--- a/x11-misc/sw-notify-send/Manifest
+++ b/x11-misc/sw-notify-send/Manifest
@@ -1,4 +1,4 @@
DIST sw-notify-send-0.1.c.bz2 1732 RMD160 e43ac679a5da4ae467917f3fa48171046513e8df SHA1 1d38b31510710abdb30cf1bd523890e48bf74d5f SHA256 e58a66d3bd419287ea47d507027c0b08cd1451dc4c88bb70f6810ae2734596b8
-EBUILD sw-notify-send-0.1.ebuild 849 RMD160 4ed1b10407c4f7adbe9fdb8e8463729fdd4dbbc7 SHA1 46a8982c4b4b4c536e8b29617ed2d40cce4471eb SHA256 e54d40d5cf31d94f885e206b1025bc3cf4642774cde755a1de29d82085091b2c
-MISC ChangeLog 431 RMD160 b7ec18eed15dd9d24e8fdc54e17594c4b6d606fc SHA1 3e0cc2b12c98677337606da2d7fb94d2c2f766fc SHA256 4781607a77c60d3150ca2fe9b41b47bb55f8927da943067a15bcf9e0c73486b1
+EBUILD sw-notify-send-0.1.ebuild 824 RMD160 15cbe3cf9d32bc0a7225d707b7ad6e2ddb2e470a SHA1 c22bdeb969f83296368efecdae34eed7e6ef6ce6 SHA256 5b1aaba2d9445c372d0e3409ce7c47a5a16ba69c8339f6f89b342018b9aaeb2c
+MISC ChangeLog 564 RMD160 4dfba629dc233082ec4258fc25745cb2b30d42ec SHA1 2eccb75b8f6ac934e8e535ebd8894b94ec6af501 SHA256 b693e206664a4a4462cfd9fe43c82ca813317448f33563270ada40605472933d
MISC metadata.xml 231 RMD160 6aebfea93d789d2b96ea6d8259dc842dd1fdacd3 SHA1 e10a04c4c18a66af326abc1f40c61b28cc610fae SHA256 48054ea190d00518c1e035fc6663b2368854cdea5ff69a94830e4f9a38260987
diff --git a/x11-misc/sw-notify-send/sw-notify-send-0.1.ebuild b/x11-misc/sw-notify-send/sw-notify-send-0.1.ebuild
index 072a7cb90..4714c9ea9 100644
--- a/x11-misc/sw-notify-send/sw-notify-send-0.1.ebuild
+++ b/x11-misc/sw-notify-send/sw-notify-send-0.1.ebuild
@@ -22,9 +22,10 @@ RDEPEND="${DEPEND}"
# a libnotify notification daemon implies having libnotify installed.
src_compile() {
- "$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ${P}.c -o ${PN} -lproc || die
+ tc-export CC
+ emake LDLIBS=-lproc ${P} || die
}
src_install() {
- dobin ${PN} || die
+ newbin ${P} ${PN} || die
}