summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-07-12 19:02:34 +0000
committerCédric Krier <cedk@gentoo.org>2006-07-12 19:02:34 +0000
commitc5d28b5906c1f39d56d4944ebfe4e947eb167c3f (patch)
tree581e4f692c1ff514a75f88649c681f2423f0eb09 /x11-misc/xorg-edit/files/xorg-edit-06.06.11-makefile.patch
parentwill be added to portage directly (diff)
downloadsunrise-c5d28b5906c1f39d56d4944ebfe4e947eb167c3f.tar.gz
sunrise-c5d28b5906c1f39d56d4944ebfe4e947eb167c3f.tar.bz2
sunrise-c5d28b5906c1f39d56d4944ebfe4e947eb167c3f.zip
x11-misc/xorg-edit: New Ebuild for bug 139850 thanks to Priyantha Bleeker and Jakub Moc
svn path=/sunrise/; revision=597
Diffstat (limited to 'x11-misc/xorg-edit/files/xorg-edit-06.06.11-makefile.patch')
-rw-r--r--x11-misc/xorg-edit/files/xorg-edit-06.06.11-makefile.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/xorg-edit/files/xorg-edit-06.06.11-makefile.patch b/x11-misc/xorg-edit/files/xorg-edit-06.06.11-makefile.patch
new file mode 100644
index 000000000..429d0745d
--- /dev/null
+++ b/x11-misc/xorg-edit/files/xorg-edit-06.06.11-makefile.patch
@@ -0,0 +1,31 @@
+--- xorg-edit~/sources/Makefile 2006-07-12 19:33:14.000000000 +0200
++++ xorg-edit/sources/Makefile 2006-07-12 20:01:46.000000000 +0200
+@@ -5,7 +5,9 @@
+
+ # variables
+
+-CXX = `wx-config --cxx`
++CXX ?= `wx-config --cxx`
++LDFLAGS+=`wx-config --libs`
++CXXFLAGS+=`wx-config --cxxflags`
+
+ PROGRAM = xorg-edit
+
+@@ -17,14 +19,12 @@
+
+ all: $(PROGRAM)
+
+- rm -f *.o
+
+ $(PROGRAM): $(OBJECTS)
+- $(CXX) -o $(PROGRAM) $(OBJECTS) `wx-config --libs`
+-
+-$(OBJECTS): $(SOURCES)
+- $(CXX) -c $(SOURCES) `wx-config --cxxflags`
++ $(CXX) -o $(PROGRAM) $(OBJECTS) $(LDFLAGS)
+
++%.o: %.c
++ $(CXX) -o $@ -c $< $(CXXFLAGS)
+
+ clean:
+ rm -f *.o $(PROGRAM)