summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-08-12 18:55:32 +0000
committerCédric Krier <cedk@gentoo.org>2006-08-12 18:55:32 +0000
commitdff669dca3c9fd18eaf4168fe60b0a8135a0a4dd (patch)
tree82eaddb2582790830749a1516f10e05445af4b29 /x11-misc/xorg-edit/files/xorg-edit-06.08.02-makefile.patch
parentudept is now in portage (diff)
downloadsunrise-dff669dca3c9fd18eaf4168fe60b0a8135a0a4dd.tar.gz
sunrise-dff669dca3c9fd18eaf4168fe60b0a8135a0a4dd.tar.bz2
sunrise-dff669dca3c9fd18eaf4168fe60b0a8135a0a4dd.zip
x11-misc/xorg-edit: Version bump
svn path=/sunrise/; revision=866
Diffstat (limited to 'x11-misc/xorg-edit/files/xorg-edit-06.08.02-makefile.patch')
-rw-r--r--x11-misc/xorg-edit/files/xorg-edit-06.08.02-makefile.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/xorg-edit/files/xorg-edit-06.08.02-makefile.patch b/x11-misc/xorg-edit/files/xorg-edit-06.08.02-makefile.patch
new file mode 100644
index 000000000..70747862e
--- /dev/null
+++ b/x11-misc/xorg-edit/files/xorg-edit-06.08.02-makefile.patch
@@ -0,0 +1,32 @@
+diff -ru xorg-edit~/sources/Makefile xorg-edit/sources/Makefile
+--- xorg-edit~/sources/Makefile 2006-08-12 20:46:06.000000000 +0200
++++ xorg-edit/sources/Makefile 2006-08-12 20:49:18.000000000 +0200
+@@ -5,7 +5,9 @@
+
+ # variables
+
+-CXX = `wx-config --cxx`
++CXX ?= `wx-config --cxx`
++LDFLAGS+=`wx-config --libs`
++CXXFLAGS+=`wx-config --cxxflags`
+
+ PROGRAM = xorg-edit
+
+@@ -17,14 +19,12 @@
+
+ all: $(PROGRAM)
+
+- rm -f *.o
+
+ $(PROGRAM): $(OBJECTS)
+- $(CXX) -o $(PROGRAM) $(OBJECTS) `wx-config --libs`
+-
+-$(OBJECTS): $(SOURCES)
+- $(CXX) -c $(SOURCES) `wx-config --cxxflags`
++ $(CXX) -o $(PROGRAM) $(OBJECTS) $(LDFLAGS)
+
++%.o: %.c
++ $(CXX) -o $@ -c $< $(CXXFLAGS)
+
+ clean:
+ rm -f *.o $(PROGRAM)