summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-03-31 16:14:56 +0000
committerhasufell <julian.ospald@googlemail.com>2012-03-31 16:14:56 +0000
commit1e69cd9504d3a576dd3d406d4421ed94c04c9f4b (patch)
tree23e2f001782ef8a86ddc0e95159638662f4f344d /x11-misc
parentx11-misc/spacefm-dmenu-plugin: drop empty einfo lines (diff)
downloadsunrise-1e69cd9504d3a576dd3d406d4421ed94c04c9f4b.tar.gz
sunrise-1e69cd9504d3a576dd3d406d4421ed94c04c9f4b.tar.bz2
sunrise-1e69cd9504d3a576dd3d406d4421ed94c04c9f4b.zip
x11-misc/spacefm-pdfmerge-plugin: New Ebuild for bug 410083 thanks to Tommy[D]
svn path=/sunrise/; revision=12889
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/spacefm-pdfmerge-plugin/ChangeLog10
-rw-r--r--x11-misc/spacefm-pdfmerge-plugin/Manifest4
-rw-r--r--x11-misc/spacefm-pdfmerge-plugin/metadata.xml7
-rw-r--r--x11-misc/spacefm-pdfmerge-plugin/spacefm-pdfmerge-plugin-0.1.ebuild41
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/spacefm-pdfmerge-plugin/ChangeLog b/x11-misc/spacefm-pdfmerge-plugin/ChangeLog
new file mode 100644
index 000000000..a0c181777
--- /dev/null
+++ b/x11-misc/spacefm-pdfmerge-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/spacefm-pdfmerge-plugin
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*spacefm-pdfmerge-plugin-0.1 (31 Mar 2012)
+
+ 31 Mar 2012; hasufell <julian.ospald@googlemail.com>
+ +spacefm-pdfmerge-plugin-0.1.ebuild, +metadata.xml:
+ New Ebuild for bug 410083 thanks to Tommy[D]
+
diff --git a/x11-misc/spacefm-pdfmerge-plugin/Manifest b/x11-misc/spacefm-pdfmerge-plugin/Manifest
new file mode 100644
index 000000000..6d0271dbe
--- /dev/null
+++ b/x11-misc/spacefm-pdfmerge-plugin/Manifest
@@ -0,0 +1,4 @@
+DIST PDFs-merge_v0.1.spacefm-plugin.tar.gz 15107 RMD160 8136b17d019fcd6902194c437007068349a1d16b SHA1 0afc8dd6ea76702a82ee049cfe7dd57a6b8a7181 SHA256 724d833c5a1f3d880bb5a1edd404f6f45bb37b9a89c548f78aa342a4fd2126ba
+EBUILD spacefm-pdfmerge-plugin-0.1.ebuild 1169 RMD160 82596f47f7e4253641d9416bb368f48b2f02f9fc SHA1 479515846004f892112155501672d88f0625c745 SHA256 99b0133dacc29f8b7a9d1b4d4d93db8d56ad5912d794e1d342e1a630d7d0b384
+MISC ChangeLog 334 RMD160 6cae2ef64135f562f34ce5dc69c2c924f789d0c4 SHA1 163cb91eaf6df58588088ab1e84d7ef2309e8532 SHA256 d5f3ae6c1ac86b0088a2dcaa69a80d7ec0ba1aabfbd51ad2ce56e60e0d315e05
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/x11-misc/spacefm-pdfmerge-plugin/metadata.xml b/x11-misc/spacefm-pdfmerge-plugin/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/x11-misc/spacefm-pdfmerge-plugin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/spacefm-pdfmerge-plugin/spacefm-pdfmerge-plugin-0.1.ebuild b/x11-misc/spacefm-pdfmerge-plugin/spacefm-pdfmerge-plugin-0.1.ebuild
new file mode 100644
index 000000000..0b4d93cfe
--- /dev/null
+++ b/x11-misc/spacefm-pdfmerge-plugin/spacefm-pdfmerge-plugin-0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Merge multipled PDF files to one"
+HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/pdfs-merge/pdfs-merge"
+SRC_URI="http://bashscripts.googlecode.com/files/PDFs-merge_v${PV}.spacefm-plugin.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/ghostscript-gpl
+ x11-misc/spacefm"
+
+S=${WORKDIR}
+
+src_install() {
+ find -name COPYING -delete
+ insinto /usr/share/spacefm/plugins/pdfmerge
+ doins -r cstm_* plugin
+ insinto /usr/share/spacefm/plugin-files
+ doins "${DISTDIR}"/PDFs-merge_v${PV}.spacefm-plugin.tar.gz
+
+ cd "${D}"
+ find . -name "exec.sh" -exec fperms +x '{}' + || die
+}
+
+pkg_postinst() {
+ einfo "You might need to restart spacefm for the changes to take effect."
+ elog "If you want to add a plugin to a different menu via design-mode"
+ elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
+}
+
+pkg_postrm() {
+ elog "If you have copied the plugin to a different menu using the"
+ elog "design mode you might want to remove it from there as well."
+}