summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2006-09-16 10:20:36 +0000
committerCédric Krier <cedk@gentoo.org>2006-09-16 10:20:36 +0000
commit74db05820f9457d9e5ed58d6ed5287b675ac53f4 (patch)
tree62c19a3373369e243f9550fb3b60ab6b7642b000 /x11-wm/dwm/dwm-1.5.ebuild
parentmedia-sound/lmms: Removed ~amd64 from lmms-0.2.1-r1.ebuild. Restored lmms-0.2... (diff)
downloadsunrise-74db05820f9457d9e5ed58d6ed5287b675ac53f4.tar.gz
sunrise-74db05820f9457d9e5ed58d6ed5287b675ac53f4.tar.bz2
sunrise-74db05820f9457d9e5ed58d6ed5287b675ac53f4.zip
x11-wm/dwm: Version bump
svn path=/sunrise/; revision=1256
Diffstat (limited to 'x11-wm/dwm/dwm-1.5.ebuild')
-rw-r--r--x11-wm/dwm/dwm-1.5.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/x11-wm/dwm/dwm-1.5.ebuild b/x11-wm/dwm/dwm-1.5.ebuild
deleted file mode 100644
index 8bf71946f..000000000
--- a/x11-wm/dwm/dwm-1.5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="a dynamic window manager for X11"
-HOMEPAGE="http://www.shortest.de/view/dynamic+window+manager"
-SRC_URI="http://www.shortest.de/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="savedconfig"
-
-DEPEND="x11-libs/libX11"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-config_mk.patch"
- epatch "${FILESDIR}/${P}-makefile.patch"
-
- if use savedconfig; then
- local conf root
- [[ -r config.h ]] && rm config.h
- for conf in ${PF} ${P} ${PN}; do
- for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
- configfile=${root}etc/portage/savedconfig/${conf}.config.h
- if [[ -r ${configfile} ]]; then
- elog "Found your ${configfile} and using it."
- cp ${configfile} "${S}"/config.h
- return 0
- fi
- done
- done
- ewarn "Could not locate user configfile, so we will save a default one."
- fi
-}
-
-src_compile() {
- local msg
- use savedconfig && msg=", please check the configfile"
- emake CC=$(tc-getCC) || die "emake failed${msg}"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
-
- insinto /usr/share/${PN}
- newins config.h ${PF}.config.h
-
- dodoc README
-}
-
-pkg_preinst() {
- mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/
-}
-
-pkg_postinst() {
- if use savedconfig; then
- local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
- elog "Saving this build config to ${config_dir}/${PF}.config.h"
- einfo "Read this ebuild for more info on how to take advantage of this option."
- mkdir -p "${config_dir}"
- cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
- fi
- einfo "This ebuild has support for user defined configs"
- einfo "Please read this ebuild for more details and re-emerge as needed"
- einfo "if you want to add or remove functionality for ${PN}"
- if ! has_version x11-misc/dmenu; then
- elog "Installing ${PN} without x11-misc/dmenu"
- einfo "To have a menu you can install x11-misc/dmenu"
- fi
-}