summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndre-Patrick Bubel (moredread) <code@andre-bubel.de>2009-05-08 15:16:40 +0000
committerAndre-Patrick Bubel (moredread) <code@andre-bubel.de>2009-05-08 15:16:40 +0000
commita343f8c2fed62bb879df85af5924cfe6e06fab94 (patch)
treeb7793344932b2b5d3d00722472e1d21517e1ac12 /x11-wm/i3/i3-3a_p2.ebuild
parentFixed DEPEND/RDEPEND, whitespace. Add QA_TEXTRELS and QA_PRESTRIPPED. Fix sym... (diff)
downloadsunrise-a343f8c2fed62bb879df85af5924cfe6e06fab94.tar.gz
sunrise-a343f8c2fed62bb879df85af5924cfe6e06fab94.tar.bz2
sunrise-a343f8c2fed62bb879df85af5924cfe6e06fab94.zip
x11-wm/i3: Version bump for i3, thanks to scarabeus
svn path=/sunrise/; revision=8505
Diffstat (limited to 'x11-wm/i3/i3-3a_p2.ebuild')
-rw-r--r--x11-wm/i3/i3-3a_p2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-wm/i3/i3-3a_p2.ebuild b/x11-wm/i3/i3-3a_p2.ebuild
new file mode 100644
index 000000000..1d7002b0a
--- /dev/null
+++ b/x11-wm/i3/i3-3a_p2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_P="${PN}-3.a-bf2"
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3.zekjur.net/"
+SRC_URI="http://i3.zekjur.net/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/xcb-util-0.3.3
+ >=x11-libs/libxcb-1.1.90.1
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ >=app-text/asciidoc-8.1.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake || die "emake failed"
+ emake -C man || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc GOALS TODO || die "dodoc ${PN} failed"
+
+ doman man/${PN}.1 || die "doman ${PN} failed"
+
+ echo -e "#!/bin/sh\n/usr/bin/${PN}" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}" || die "doexe ${PN} failes"
+}