summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pygooglechart/ChangeLog8
-rw-r--r--dev-python/pygooglechart/Manifest4
-rw-r--r--dev-python/pygooglechart/metadata.xml8
-rw-r--r--dev-python/pygooglechart/pygooglechart-0.3.0.ebuild42
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pygooglechart/ChangeLog b/dev-python/pygooglechart/ChangeLog
new file mode 100644
index 000000000..9f02e967d
--- /dev/null
+++ b/dev-python/pygooglechart/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/pygooglechart
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 Jan 2011; Mike Gilbert (floppym) <floppymaster@gmail.com>
+ +pygooglechart-0.3.0.ebuild, +metadata.xml:
+ New ebuild for bug 242132
+
diff --git a/dev-python/pygooglechart/Manifest b/dev-python/pygooglechart/Manifest
new file mode 100644
index 000000000..76a09dbd3
--- /dev/null
+++ b/dev-python/pygooglechart/Manifest
@@ -0,0 +1,4 @@
+DIST pygooglechart-0.3.0.tar.gz 27388 RMD160 0e270c325d58f180773f5d7ef8290bd14d4126a6 SHA1 5aadf5419ad799168dfd1aa085fac8c3ddff2dfb SHA256 f9a6fac4543c592381ccdc6b6384016c283ab74e15891c67593ff1b6167cee4d
+EBUILD pygooglechart-0.3.0.ebuild 1039 RMD160 17867fa33afe7310ebe6d92ba555d92bb893381a SHA1 793cea0f25ccc764304e9cacd2626eab40e6e82d SHA256 906f88f1241f10c055d45c083bee439fe325c3019d8706d5fce21f20ec7c5a3f
+MISC ChangeLog 263 RMD160 32a64676f6f0291eaa4897738f5660d17a528298 SHA1 1e2943af0c12c93d3368d11b49ca6b733c462076 SHA256 f03d667a2cc6ecd8dc119aff974ec16ccf377e250b4de54d0a9c0f284af79a2e
+MISC metadata.xml 236 RMD160 436d0d621f57d67fdc9f26b237dd3fea1250d098 SHA1 47f6942e8f7c8698f50cdefc101c4ba7218cfe60 SHA256 a13a64b5acaf180f7646044ce3ee8b8071157d4e84589641c239d50a59c48981
diff --git a/dev-python/pygooglechart/metadata.xml b/dev-python/pygooglechart/metadata.xml
new file mode 100644
index 000000000..5e101193f
--- /dev/null
+++ b/dev-python/pygooglechart/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pygooglechart/pygooglechart-0.3.0.ebuild b/dev-python/pygooglechart/pygooglechart-0.3.0.ebuild
new file mode 100644
index 000000000..c4e52a8e1
--- /dev/null
+++ b/dev-python/pygooglechart/pygooglechart-0.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils python
+
+DESCRIPTION="A complete Python wrapper for the Google Chart API"
+HOMEPAGE="http://pygooglechart.slowchop.com/"
+SRC_URI="http://pygooglechart.slowchop.com/files/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ test? ( dev-python/PyQrcodec )"
+RDEPEND=""
+
+# Tests currently fail
+RESTRICT="test"
+PYTHON_MODNAME="${PN}.py"
+
+src_test() {
+ # The test scripts import the test.test_base module; need this to get python
+ # to recognize the test module.
+ touch test/__init__.py
+
+ testing() {
+ # python_execute_function will die if this function returns a non-zero
+ # exit status.
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_general.py && \
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_bugs.py
+ }
+ python_execute_function testing
+}