summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-visualization/spyview/ChangeLog8
-rw-r--r--sci-visualization/spyview/metadata.xml7
-rw-r--r--sci-visualization/spyview/spyview-20090828.ebuild44
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-visualization/spyview/ChangeLog b/sci-visualization/spyview/ChangeLog
new file mode 100644
index 000000000..8eee7082d
--- /dev/null
+++ b/sci-visualization/spyview/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-visualization/spyview
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 01 Sep 2009; Andreas K. Huettel (dilfridge) <mail@akhuettel.de>
+ +spyview-20090828.ebuild, +metadata.xml:
+ New Ebuild for bug 283449
+
diff --git a/sci-visualization/spyview/metadata.xml b/sci-visualization/spyview/metadata.xml
new file mode 100644
index 000000000..e4979b9b0
--- /dev/null
+++ b/sci-visualization/spyview/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <use>
+ </use>
+</pkgmetadata>
diff --git a/sci-visualization/spyview/spyview-20090828.ebuild b/sci-visualization/spyview/spyview-20090828.ebuild
new file mode 100644
index 000000000..64aa1367e
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20090828.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI=2
+
+inherit base flag-o-matic
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/boost-1.36
+ media-libs/netpbm
+ x11-libs/fltk:1.1
+ virtual/ghostscript"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/spyview-2009-08-28-23_55
+
+src_configure() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L/usr/lib/fltk-1.1
+
+ econf --datadir=/usr/share/spyview
+}
+
+
+