summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/gizmod/ChangeLog8
-rw-r--r--app-misc/gizmod/Manifest4
-rw-r--r--app-misc/gizmod/files/digest-gizmod-3.03
-rw-r--r--app-misc/gizmod/gizmod-3.0.ebuild38
-rw-r--r--app-misc/gizmod/metadata.xml5
5 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/gizmod/ChangeLog b/app-misc/gizmod/ChangeLog
new file mode 100644
index 000000000..24f8f2007
--- /dev/null
+++ b/app-misc/gizmod/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-misc/gizmod
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 May 2007; Your Name (flithm) <tim@timburrell.net> +gizmod-3.0.ebuild,
+ +metadata.xml:
+ New Ebuild for bug 134016
+
diff --git a/app-misc/gizmod/Manifest b/app-misc/gizmod/Manifest
new file mode 100644
index 000000000..da8b038b8
--- /dev/null
+++ b/app-misc/gizmod/Manifest
@@ -0,0 +1,4 @@
+DIST gizmod-3.0.tar.bz2 329075 RMD160 cea42151a86c03b6071310c45ebb1ca8fbfe5744 SHA1 6e746aa8514ae1e475d9609ed9c6e286ee3bfc4f SHA256 685b88955e348c5ea92224fbdb3b351999d42148a058772f5655ce2e257e0c97
+EBUILD gizmod-3.0.ebuild 1113 RMD160 7ee257adaa55e5e2d74b17041143874e7747d0ac SHA1 f89d8bc255aaaa95fcc3b229b51e46fd94ab5541 SHA256 b4f8a5fda8a0b307170edc116adfcb39c3d1de36536233ad03121a8dff0d6bc0
+MISC ChangeLog 237 RMD160 b0efbd3a4ea45becf2916829dc4aedfce5e7b8bb SHA1 47a65b6dc17b36ad1f9a4e537eae2deeac1c40f7 SHA256 c7ae6026f1d66a247b92f17e2586237367efe5b43aa45d122aa18fccc0e905cf
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-misc/gizmod/files/digest-gizmod-3.0 b/app-misc/gizmod/files/digest-gizmod-3.0
new file mode 100644
index 000000000..ca7de7c14
--- /dev/null
+++ b/app-misc/gizmod/files/digest-gizmod-3.0
@@ -0,0 +1,3 @@
+MD5 536f0131302df478f8b254eee28663e8 gizmod-3.0.tar.bz2 329075
+RMD160 cea42151a86c03b6071310c45ebb1ca8fbfe5744 gizmod-3.0.tar.bz2 329075
+SHA256 685b88955e348c5ea92224fbdb3b351999d42148a058772f5655ce2e257e0c97 gizmod-3.0.tar.bz2 329075
diff --git a/app-misc/gizmod/gizmod-3.0.ebuild b/app-misc/gizmod/gizmod-3.0.ebuild
new file mode 100644
index 000000000..10df3b0d4
--- /dev/null
+++ b/app-misc/gizmod/gizmod-3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Input event scripting utility that has special support for fancy keyboards and mice, USB dials, LIRC and USB remotes, and more."
+HOMEPAGE="http://gizmod.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="libvisual"
+RDEPEND="x11-libs/libX11
+ dev-lang/python
+ media-libs/alsa-lib
+ dev-libs/boost
+ libvisual? ( >=media-libs/libvisual-0.4.0 )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/boost threads ; then
+ eerror "boost was not merged with the threads"
+ eerror "USE flag. Gizmo Daemon requires boost be"
+ eerror "built with this flag"
+ die "boost missing threads support"
+ fi
+}
+
+src_compile() {
+ econf --with-boost $(use_enable libvisual visplugin) || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+}
diff --git a/app-misc/gizmod/metadata.xml b/app-misc/gizmod/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/app-misc/gizmod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>