summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ahcpd/ChangeLog8
-rw-r--r--net-misc/ahcpd/Manifest6
-rw-r--r--net-misc/ahcpd/ahcpd-0.51.ebuild (renamed from net-misc/ahcpd/ahcpd-0.5.ebuild)10
3 files changed, 14 insertions, 10 deletions
diff --git a/net-misc/ahcpd/ChangeLog b/net-misc/ahcpd/ChangeLog
index 1233e1d4d..44eccf89c 100644
--- a/net-misc/ahcpd/ChangeLog
+++ b/net-misc/ahcpd/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-misc/ahcpd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*ahcpd-0.51 (07 Jul 2010)
+
+ 07 Jul 2010; Michał Górny (sedzimir) <mgorny.3ehbo@mailnull.com>
+ -ahcpd-0.5.ebuild, +ahcpd-0.51.ebuild:
+ Version bump, cleanup. Pass CC.
+
29 Mar 2009; Bignaux Ronan <ronan@aimao.org> ahcpd-0.5.ebuild:
remove useless MANDIR and INFODIR parameters for emake install
diff --git a/net-misc/ahcpd/Manifest b/net-misc/ahcpd/Manifest
index 00c569951..9f8f07d9e 100644
--- a/net-misc/ahcpd/Manifest
+++ b/net-misc/ahcpd/Manifest
@@ -1,4 +1,4 @@
-DIST ahcpd-0.5.tar.gz 34302 RMD160 667280860ba56e90ca0780ff44f0f774590631dd SHA1 fda7c6151e4ebf11949250ef555becd9387a5ca7 SHA256 cd4a632fb548aa3224cf441260bfe13440cad2ccb15e2dc425b513505946b8e5
-EBUILD ahcpd-0.5.ebuild 575 RMD160 f37e1bec7bc91ce9715b9f098bd37a6895a70330 SHA1 30d43c7a8bbc66eba150d77e603d31898cdde8a4 SHA256 fdef8d22a08922dbe79b5a0e70fc856f1c56210e785efc2ca4775098fd47b23a
-MISC ChangeLog 459 RMD160 4ba8aae03b35dae7a678bda69988af3bf0f1c5c0 SHA1 bb4b636e841ec379d5e1c30d88e748a714d38f39 SHA256 135c390470d977f9a9ab23eee5a7e779c723f4c0a6e27d726faa4b707d8296db
+DIST ahcpd-0.51.tar.gz 29523 RMD160 8fcaaf5a7b5be315c3eb71d520b340eabb699fbe SHA1 cb2490317f8a1c7e0c59c614eeb3a81104791f16 SHA256 2b43927fe2dbe978b0cb21770845608ab612602187e642cb421e8d01249fba30
+EBUILD ahcpd-0.51.ebuild 553 RMD160 3765e8c579e9908f133fbf5c5d57542a4b95a808 SHA1 01315c412972a1370992dc15fb1b643da88937d6 SHA256 5f8d274123be0970f85ba1c3d8c3b251bee77147bd6ed1254504e620595b2056
+MISC ChangeLog 631 RMD160 4ff020ca353bfe4a64b8396b0c55f84c437dea90 SHA1 b54524877a3de089b2cb404c7ebc49840dc0a701 SHA256 2e22ad9b2baff31719bf01c9a38458cbb251c2da950e4e6ca93e502f9872aab3
MISC metadata.xml 245 RMD160 4b6d28ac6d11318e46608b660faa66831e687abd SHA1 121cfd33e7fd68c5698748ef5d191a4c25ab00ce SHA256 bb00019a125967806b1ac6fdb192689e4d1ff8215f6749b7bef027d19f94428d
diff --git a/net-misc/ahcpd/ahcpd-0.5.ebuild b/net-misc/ahcpd/ahcpd-0.51.ebuild
index c46a6c7de..605b35147 100644
--- a/net-misc/ahcpd/ahcpd-0.5.ebuild
+++ b/net-misc/ahcpd/ahcpd-0.51.ebuild
@@ -2,11 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+inherit toolchain-funcs
-inherit eutils
-
-DESCRIPTION="the Ad-Hoc Configuration Protocol"
+DESCRIPTION="Daemon for configuring a network using AHCP"
HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/ahcp/"
SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
@@ -16,10 +14,10 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
src_compile() {
- emake PREFIX=/usr "CDEBUGFLAGS=${CFLAGS}" all || die "build failed"
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" || die
}
src_install(){
- emake install PREFIX=/usr "TARGET=${D}" || die "install failed"
+ emake install PREFIX=/usr TARGET="${D}" || die
dodoc CHANGES README || die
}