summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-antivirus/panda/ChangeLog7
-rw-r--r--app-antivirus/panda/Manifest12
-rw-r--r--app-antivirus/panda/files/digest-panda-9.00.003
-rw-r--r--app-antivirus/panda/panda-9.00.00.ebuild43
4 files changed, 65 insertions, 0 deletions
diff --git a/app-antivirus/panda/ChangeLog b/app-antivirus/panda/ChangeLog
new file mode 100644
index 000000000..22fd85d4b
--- /dev/null
+++ b/app-antivirus/panda/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for app-antivirus/panda
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 10 Jun 2006; Jakub Moc <jakub@gentoo.org> +panda-9.00.00.ebuild:
+ New ebuild, initially submitted by Francisco Javier in Bug 78969.
+
diff --git a/app-antivirus/panda/Manifest b/app-antivirus/panda/Manifest
new file mode 100644
index 000000000..60c8ac7bf
--- /dev/null
+++ b/app-antivirus/panda/Manifest
@@ -0,0 +1,12 @@
+DIST pavcl_linux.tgz 7993107 RMD160 8695977b1c5402969d72b89abc92b10c8d9a30fa SHA1 c4803efadd17e3caddb4ef1610cec3ed5beac656 SHA256 a72c9fd4f76fd801800711d804e98d01b3cd7abb5843755518e1dfbb9bfc7612
+EBUILD panda-9.00.00.ebuild 1087 RMD160 69d2e5b9ca46a1d58e754d0920ce4642b4d9015b SHA1 8807346697410f429eefe8a65259af7df1d15c1f SHA256 f5670097e31e8a2ae9c976c159c52235f1caaf4502de62499959b0142cb4dd50
+MD5 a8e0dcb4b273b4765aa9b5a0d68121d3 panda-9.00.00.ebuild 1087
+RMD160 69d2e5b9ca46a1d58e754d0920ce4642b4d9015b panda-9.00.00.ebuild 1087
+SHA256 f5670097e31e8a2ae9c976c159c52235f1caaf4502de62499959b0142cb4dd50 panda-9.00.00.ebuild 1087
+MISC ChangeLog 256 RMD160 bc3d4b2144a3bdba24353d63ab3cb42b9c0fdbdc SHA1 1a4432b5b0914bc9f2992e9147f2d73914744351 SHA256 73ded9f0ffbb8621d4b2cf2a84be126f805ed8dcb3738ad8a07664ba6f77ef4c
+MD5 2bc34bbeab7a77d2527c57ec614d7450 ChangeLog 256
+RMD160 bc3d4b2144a3bdba24353d63ab3cb42b9c0fdbdc ChangeLog 256
+SHA256 73ded9f0ffbb8621d4b2cf2a84be126f805ed8dcb3738ad8a07664ba6f77ef4c ChangeLog 256
+MD5 528800c9da3924c0c304bd0d84cd70fd files/digest-panda-9.00.00 229
+RMD160 847efc5958ee8b1d3a2427af42acf9340bb1b10a files/digest-panda-9.00.00 229
+SHA256 7e1dcfe83de470aa854ab7b66ec0ded2ddbbc8b904ee3bef9518e5ad925c2d2a files/digest-panda-9.00.00 229
diff --git a/app-antivirus/panda/files/digest-panda-9.00.00 b/app-antivirus/panda/files/digest-panda-9.00.00
new file mode 100644
index 000000000..00e0a1d17
--- /dev/null
+++ b/app-antivirus/panda/files/digest-panda-9.00.00
@@ -0,0 +1,3 @@
+MD5 4ee45c904057889b43e66e0333767348 pavcl_linux.tgz 7993107
+RMD160 8695977b1c5402969d72b89abc92b10c8d9a30fa pavcl_linux.tgz 7993107
+SHA256 a72c9fd4f76fd801800711d804e98d01b3cd7abb5843755518e1dfbb9bfc7612 pavcl_linux.tgz 7993107
diff --git a/app-antivirus/panda/panda-9.00.00.ebuild b/app-antivirus/panda/panda-9.00.00.ebuild
new file mode 100644
index 000000000..88e78789c
--- /dev/null
+++ b/app-antivirus/panda/panda-9.00.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+S=${WORKDIR}
+
+DESCRIPTION="Panda Antivirus for Linux"
+HOMEPAGE="http://www.pandasoftware.com/download/linux/linux.asp"
+SRC_URI="http://shareware.pandasoftware.com/shareware/pavcl_linux.tgz"
+
+SLOT="0"
+LICENSE="Panda-Freeware"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+PROVIDE="virtual/antivirus"
+
+RESTRICT="mirror strip"
+QA_TEXTRELS_x86="opt/pavcl/usr/lib/libPsk*.so.*"
+
+src_install() {
+ cd ${S}
+ cp -r . ${D}
+
+ dodir /etc/env.d
+ echo "PATH=\"/opt/pavcl/usr/bin\"" >> ${D}/etc/env.d/90panda
+ echo "MANPATH=\"/opt/pavcl/usr/man\"" >> ${D}/etc/env.d/90panda
+}
+
+pkg_postinst() {
+ einfo "See \"man pavcl\" for usage instructions."
+ einfo
+ einfo "Updated virus definitions are not available for free."
+ einfo "You need a username and password to download them"
+ einfo "from http://acs.pandasoftware.com/software/basevirus/"
+}
+
+pkg_prerm() {
+ einfo "Removing stale logdir..."
+ [[ -d "${ROOT}/opt/pavcl/var/log/panda" ]] && rm -rf "${ROOT}/opt/pavcl/var/log/panda"
+}