summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild')
-rw-r--r--app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild b/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
new file mode 100644
index 000000000..5fe547b8c
--- /dev/null
+++ b/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extra configurations for zpaq"
+HOMEPAGE="http://mattmahoney.net/dc/#zpaq"
+SRC_URI="http://mattmahoney.net/dc/bwt_j3.zip
+ http://mattmahoney.net/dc/bwt_slowmode1.zip
+ http://mattmahoney.net/dc/bmp_j4.zip
+ http://mattmahoney.net/dc/exe_j1.zip
+ http://mattmahoney.net/dc/jpg_test2.zip
+ http://mattmahoney.net/dc/fast.cfg"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ local _prog
+
+ mkdir bin
+ for _prog in bwtpre bwt_ jpeg_jo exe_jo; do
+ "$(tc-getCXX)" ${CXXFLAGS} ${_prog}.cpp -o bin/${_prog} \
+ || die "compiling ${_prog} failed"
+ done
+
+ sed \
+ -e 's:^pcomp zpaq r:pcomp /usr/bin/zpaq r/usr/share/zpaq/:' \
+ -e 's:^pcomp \([^/]\):pcomp /usr/libexec/zpaq/\1:' \
+ -i *.cfg || die 'sed failed'
+}
+
+src_install() {
+ exeinto /usr/libexec/zpaq
+ doexe bin/* || die 'dobin failed'
+
+ insinto /usr/share/zpaq
+ doins *.cfg "${DISTDIR}"/*.cfg || die 'doins failed'
+}