summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/acerhdf/acerhdf-0.5.16.4.ebuild')
-rw-r--r--app-laptop/acerhdf/acerhdf-0.5.16.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-laptop/acerhdf/acerhdf-0.5.16.4.ebuild b/app-laptop/acerhdf/acerhdf-0.5.16.4.ebuild
new file mode 100644
index 000000000..b3bfc822b
--- /dev/null
+++ b/app-laptop/acerhdf/acerhdf-0.5.16.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit linux-mod versionator
+
+MY_PN=${PN}_kmod
+MY_P=${MY_PN}-$(replace_version_separator 3 - ${PV})
+
+DESCRIPTION="A kernelmodule which monitors the temperature of the aspire one netbook"
+HOMEPAGE="http://piie.net/index.php?section=acerhdf"
+SRC_URI="http://piie.net/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/linux-sources-2.6.30"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+BUILD_TARGETS="default"
+MODULE_NAMES="${PN}(:${S}:${S})"
+MODULESD_ACERHDF_DOCS="README.txt"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ if kernel_is lt 2 6 30; then
+ ewarn "This version of ${PN} needs at least kernel version 2.6.30 selected"
+ ewarn "Please set the /usr/src/linux symlink to the right version"
+ die "This version of ${PN} needs at least kernel version 2.6.30 selected"
+ fi
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ einfo "The module now starts with kernel mode off"
+ einfo "Read here http://piie.net/files/acerhdf_README.txt how to switch it on"
+}