summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mc-mp/files')
-rw-r--r--app-misc/mc-mp/files/4.1.40_pre9/ebuild-syntax.patch14
-rw-r--r--app-misc/mc-mp/files/4.1.40_pre9/gcc34.patch12
-rw-r--r--app-misc/mc-mp/files/4.1.40_pre9/mc-menu.patch221
-rw-r--r--app-misc/mc-mp/files/4.1.40_pre9/u7z.patch215
-rw-r--r--app-misc/mc-mp/files/chdir.gentoo11
-rw-r--r--app-misc/mc-mp/files/digest-mc-mp-4.1.40_pre93
-rw-r--r--app-misc/mc-mp/files/ebuild.syntax87
-rw-r--r--app-misc/mc-mp/files/mc.gentoo16
-rw-r--r--app-misc/mc-mp/files/mc.ini2
-rw-r--r--app-misc/mc-mp/files/mcserv.pamd7
-rw-r--r--app-misc/mc-mp/files/mcserv.rc31
11 files changed, 619 insertions, 0 deletions
diff --git a/app-misc/mc-mp/files/4.1.40_pre9/ebuild-syntax.patch b/app-misc/mc-mp/files/4.1.40_pre9/ebuild-syntax.patch
new file mode 100644
index 000000000..59d8afee7
--- /dev/null
+++ b/app-misc/mc-mp/files/4.1.40_pre9/ebuild-syntax.patch
@@ -0,0 +1,14 @@
+diff -Naur ../work/mc-4.1.40-pre9/PowerPack/syntax/Syntax mc-4.1.40-pre9/PowerPack/syntax/Syntax
+--- ../work/mc-4.1.40-pre9/PowerPack/syntax/Syntax 2004-08-30 22:20:44.000000000 +0400
++++ mc-4.1.40-pre9/PowerPack/syntax/Syntax 2005-04-05 10:43:52.311325800 +0400
+@@ -162,6 +162,9 @@
+ file ..\*\\.(yab|YAB])$ YaBasic\sProgram ^#!\s\*/.\*/yabasic$
+ include yabasic.syntax
+
++file .\*\\.(ebuild|eclass)$ Gentoo\sEbuild
++include ebuild.syntax
++
+ file .\*(S|s)yntax$ Syntax\sHighlighting\sdefinitions
+
+ context default cyan
+
diff --git a/app-misc/mc-mp/files/4.1.40_pre9/gcc34.patch b/app-misc/mc-mp/files/4.1.40_pre9/gcc34.patch
new file mode 100644
index 000000000..6a9fc12e8
--- /dev/null
+++ b/app-misc/mc-mp/files/4.1.40_pre9/gcc34.patch
@@ -0,0 +1,12 @@
+diff -uNr mc-4.1.40-pre9.orig/src/cons.handler.c mc-4.1.40-pre9/src/cons.handler.c
+--- mc-4.1.40-pre9.orig/src/cons.handler.c 2003-04-28 12:34:24.000000000 +0300
++++ mc-4.1.40-pre9/src/cons.handler.c 2005-12-09 10:07:30.000000000 +0200
+@@ -205,6 +205,7 @@
+ break;
+ default:
+ /* Nothing */
++ ;
+ }
+ }
+
+
diff --git a/app-misc/mc-mp/files/4.1.40_pre9/mc-menu.patch b/app-misc/mc-mp/files/4.1.40_pre9/mc-menu.patch
new file mode 100644
index 000000000..9e84284f9
--- /dev/null
+++ b/app-misc/mc-mp/files/4.1.40_pre9/mc-menu.patch
@@ -0,0 +1,221 @@
+diff -Naur ../work/mc-4.1.40-pre9/lib/mc.menu mc-4.1.40-pre9/lib/mc.menu
+--- ../work/mc-4.1.40-pre9/lib/mc.menu 2004-08-30 23:29:14.000000000 +0400
++++ mc-4.1.40-pre9/lib/mc.menu 2005-04-05 09:33:31.906924792 +0400
+@@ -27,14 +27,23 @@
+ info
+
+ = t d
+-3 Make a release of the current subdirectory
++3 Compress the current subdirectory (tar.gz)
++ Pwd=`basename "%d" /`
++ echo -n "Name of the compressed file (without extension) [$Pwd]: "
++ read tar
++ if [ "$tar"x = x ]; then tar="$Pwd"; fi
++ cd .. && \
++ tar cf - "$Pwd" | gzip -f9 > "$tar.tar.gz" && \
++ echo "../$tar.tar.gz created."
++
++4 Compress the current subdirectory (tar.bz2)
+ Pwd=`basename %d /`
+- echo -n "Name of the distribution file (without extension) [$Pwd]: "
++ echo -n "Name of the compressed file (without extension) [$Pwd]: "
+ read tar
+- if [ "$tar"x = x ]; then tar=$Pwd; fi
+- cd .. && tar chf - $Pwd | gzip -f9 > $tar.tar.gz
+- echo ../${tar}.tar.gz created.
+-# tar=%{Name of the distribution file (without extension)}
++ if [ "$tar"x = x ]; then tar="$Pwd"; fi
++ cd .. && \
++ tar cf - "$Pwd" | bzip2 -f > "$tar.tar.bz2" && \
++ echo "../$tar.tar.bz2 created."
+
+ = f \.c$ & t r
+ + f \.c$ & t r & ! t t
+@@ -178,15 +187,27 @@
+ fi
+ echo "Please test the output file before deleting anything"
+
+-=+ f \.tar\.gz$ | f \.tar\.z$ | f \.tgz$ | f \.tpz$ | f \.tar\.Z$ & t r
++=+ f \.tar\.gz$ | f \.tar\.z$ | f \.tgz$ | f \.tpz$ | f \.tar\.Z$| f \.tar\.bz2$ & t r
+ x Extract the contents of a compressed tar file
+- tar xzvf %f
++ unset EXT
++ case %f in
++ *.tar.bz2) EXT=tar_bz2;;
++ esac
++ if [ "$EXT" = "tar_bz2" ]
++ then
++ bunzip2 -c %f | tar xvf -
++ else
++ gzip -dc %f | tar xvf -
++ fi
+
+ = t r
+ + ! t t
+ y Gzip or gunzip current file
+ unset DECOMP
+- echo %f|egrep -q "\.gz$|\.z$|\.Z$" && DECOMP=-d
++ case %f in
++ *.gz) DECOMP=-d;;
++ *.[zZ]) DECOMP=-d;;
++ esac
+ gzip $DECOMP -v %f
+
+ + t t
+@@ -194,54 +215,126 @@
+ for i in %t
+ do
+ unset DECOMP
+- echo $i|egrep -q "\.gz$|\.z$|\.Z$" && DECOMP=-d
++ case $i in
++ *.gz) DECOMP=-d;;
++ *.[zZ]) DECOMP=-d;;
++ esac
+ gzip $DECOMP -v $i
+ done
+
+-+ f \.tar.gz$ | f \.tgz$ | f \.tpz$ | f \.tar.Z$ | f \.tar.z$ & t r & ! t t
+++ ! t t
++b Bzip2 or bunzip2 current file
++ unset DECOMP
++ case %f in
++ *.bz2) DECOMP=-d;;
++ esac
++ bzip2 $DECOMP -v %f
++
+++ t t
++B Bzip2 or bunzip2 tagged files
++ for i in %t
++ do
++ unset DECOMP
++ case $i in
++ *.bz2) DECOMP=-d;;
++ esac
++ bzip2 $DECOMP -v $i
++ done
++
+++ f \.tar.gz$ | f \.tgz$ | f \.tpz$ | f \.tar.Z$ | f \.tar.z$ | f \.tar.bz2$ | f \.tar.F$ & t r & ! t t
+ z Extract compressed tar file to subdirectory
++ unset D
++ set gzip -cd
++ case %f in
++ *.tar.gz) D="`basename %f .tar.gz`";;
++ *.tgz) D="`basename %f .tgz`";;
++ *.tpz) D="`basename %f .tpz`";;
++ *.tar.Z) D="`basename %f .tar.Z`";;
++ *.tar.z) D="`basename %f .tar.z`";;
++ *.tar.bz2) D="`basename %f .tar.bz2`"; set bunzip2 -c ;;
++ *.tar.F) D="`basename %f .tar.F`"; set freeze -dc;
++ esac
++ mkdir $D; cd $D && ($1 $2 ../%f | tar xvf -)
++
+++ t t
++Z Extract compressed tar files to subdirectories
++ for i in %t
++ do
++ set gzip -dc
++ unset D
++ case $i in
++ *.tar.gz) D="`basename $i .tar.gz`";;
++ *.tgz) D="`basename $i .tgz`";;
++ *.tpz) D="`basename $i .tpz`";;
++ *.tar.Z) D="`basename $i .tar.Z`";;
++ *.tar.z) D="`basename $i .tar.z`";;
++ *.tar.F) D="`basename $i .tar.F`"; set freeze -dc;;
++ *.tar.bz2) D="`basename $i .tar.bz2`"; set bunzip2 -c;;
++ esac
++ mkdir $D; (cd $D && $1 $2 ../$i | tar xvf -)
++ done
++
+++ f \.gz$ | f \.tgz$ | f \.tpz$ | f \.Z$ | f \.z$ | f \.bz2$ & t r & ! t t
++c Convert gz<->bz2, tar.gz<->tar.bz2 & tgz->tar.bz2
+ unset D
+- echo %f|egrep -q "\.tar.gz$" && EXT=tar_gz
+- echo %f|egrep -q "\.tgz$" && EXT=tgz
+- echo %f|egrep -q "\.tpz$" && EXT=tpz
+- echo %f|egrep -q "\.tar.Z$" && EXT=tar_Z
+- echo %f|egrep -q "\.tar.z$" && EXT=tar_z
++ case %f in
++ *.tgz) EXT=tgz;;
++ *.tpz) EXT=tpz;;
++ *.Z) EXT=Z;;
++ *.z) EXT=z;;
++ *.gz) EXT=gz;;
++ *.bz2) EXT=bz2;;
++ esac
+ case $EXT in
+- tar_gz) D="`basename %f .tar.gz`";;
+- tgz) D="`basename %f .tgz`";;
+- tpz) D="`basename %f .tpz`";;
+- tar_Z) D="`basename %f .tar.Z`";;
+- tar_z) D="`basename %f .tar.z`";;
++ tgz|tpz) D="`basename %f .$EXT`.tar";;
++ gz|Z|z) D="`basename %f .$EXT`";;
++ bz2) D="`basename %f .bz2`";;
+ esac
+- mkdir $D; cd $D && tar xvzof ../%f
++ if [ "$EXT" = "bz2" ]; then
++ bunzip2 -v %f ; gzip -f9 -v $D
++ else
++ gunzip -v %f ; bzip2 -v $D
++ fi
+
+ + t t
+-Z Extract compressed tar files to subdirectories
+- set %u
++C Convert gz<->bz2, tar.gz<->tar.bz2 & tgz->tar.bz2
++ set %t
+ while [ -n "$1" ]
+ do
+ unset D
+- echo $1|egrep -q "\.tar.gz$" && EXT=tar_gz
+- echo $1|egrep -q "\.tgz$" && EXT=tgz
+- echo $1|egrep -q "\.tpz$" && EXT=tpz
+- echo $1|egrep -q "\.tar.Z$" && EXT=tar_Z
+- echo $1|egrep -q "\.tar.z$" && EXT=tar_z
+- case $EXT in
+- tar_gz) D="`basename $1 .tar.gz`";;
+- tgz) D="`basename $1 .tgz`";;
+- tpz) D="`basename $1 .tpz`";;
+- tar_Z) D="`basename $1 .tar.Z`";;
+- tar_z) D="`basename $1 .tar.z`";;
+- esac
+- mkdir $D; (cd $D && tar xvzof ../$1)||echo tag $1 >>$MC_CONTROL_FILE
++ case $1 in
++ *.tgz) EXT=tgz;;
++ *.tpz) EXT=tpz;;
++ *.Z) EXT=Z;;
++ *.z) EXT=z;;
++ *.gz) EXT=gz;;
++ *.bz2) EXT=bz2;;
++ esac
++ case $EXT in
++ tgz) D="`basename $1 .tgz`.tar";;
++ tpz) D="`basename $1 .tpz`.tar";;
++ gz|Z|z) D="`basename $1 .$EXT`";;
++ bz2) D="`basename $1 .bz2`";;
++ esac
++ if [ "$EXT" = "bz2" ]; then
++ bunzip2 -v $1
++ gzip -f9 -v $D
++ else
++ gunzip -v $1
++ bzip2 -v $D
++ fi
+ shift
+ done
+
+++ x /usr/bin/open | x /usr/local/bin/open & x /bin/sh
++o Open next a free console
++ open -s -- sh
++
+ ##########################################################################
+ # cdrtools section by Olegarch
+
+ + t d
+-B Burn current dir [52x, JSS, koi8-r]
++J Burn current dir [52x, JSS, koi8-r]
+ COMMAND="mkisofs -a -f -jcharset koi8-r -J %d | cdrecord dev=0,0,0 speed=52 -v -data -"
+ echo Executing: ${COMMAND}
+ echo [CTRL+C to abort, ENTER to continue]
+
diff --git a/app-misc/mc-mp/files/4.1.40_pre9/u7z.patch b/app-misc/mc-mp/files/4.1.40_pre9/u7z.patch
new file mode 100644
index 000000000..e2f345919
--- /dev/null
+++ b/app-misc/mc-mp/files/4.1.40_pre9/u7z.patch
@@ -0,0 +1,215 @@
+diff -Naur ../work/mc-4.1.40-pre9/lib/mc.ext.in mc-4.1.40-pre9/lib/mc.ext.in
+--- ../work/mc-4.1.40-pre9/lib/mc.ext.in 2004-08-27 16:17:35.000000000 +0400
++++ mc-4.1.40-pre9/lib/mc.ext.in 2005-04-05 10:13:09.673449336 +0400
+@@ -152,6 +152,13 @@
+ Compile=c++ -O -c %f
+ Link=c++ -O -o %d/`basename %f .c` %f
+
++# 7zip file archive
++# This must be added before Manual pages Lines to prevent handle 7z archive
++# like man page
++regex/\.(7z|7Z)$
++ View=%view{ascii} 7za l %f 2>/dev/null
++ Open=%cd %p#u7z
++
+ ### Documentation ###
+
+ # Texinfo
+diff -Naur ../work/mc-4.1.40-pre9/vfs/extfs/extfs.ini mc-4.1.40-pre9/vfs/extfs/extfs.ini
+--- ../work/mc-4.1.40-pre9/vfs/extfs/extfs.ini 2004-08-30 01:15:20.000000000 +0400
++++ mc-4.1.40-pre9/vfs/extfs/extfs.ini 2005-04-05 10:03:06.553137560 +0400
+@@ -27,3 +27,5 @@
+ apt=
+ # ISO9660 image Virtual FileSystem
+ iso= .iso .ISO
++# 7zip file archive
++u7z=.7z .7Z
+diff -Naur ../work/mc-4.1.40-pre9/vfs/extfs/u7z mc-4.1.40-pre9/vfs/extfs/u7z
+--- ../work/mc-4.1.40-pre9/vfs/extfs/u7z 1970-01-01 03:00:00.000000000 +0300
++++ mc-4.1.40-pre9/vfs/extfs/u7z 2005-03-05 00:03:09.000000000 +0300
+@@ -0,0 +1,156 @@
++#! /bin/sh
++#
++# u7z - 7zip file archive Virtual File System for Midnight Commander ( ftp://ftp.ibiblio.org/pub/Linux/utils/file/managers/mc/ )
++#
++# Copyright (C) 2004 Sergiy Niskorodov (sgh at ukrpost dot net)
++
++# Written by Sergiy Niskorodov aka SGh
++#
++# beta version 4.14.2 (04 Mar 2005)
++#
++# 7z for linux can be found on http://sourceforge.net/projects/p7zip/
++
++
++# Thanks to urar VFS authors andrey joukov 2:5020/337.13@fidonet.org,
++# christian.gennerat@alcatel.fr, Andrew V. Samoilov <sav@bcs.zp.ua>
++# I use this script like example
++
++
++# This program is free software; you can redistribute it and/or modify
++# it under the terms of the GNU General Public License as published by
++# the Free Software Foundation; either version 2 of the License, or
++# (at your option) any later version.
++#
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++# GNU General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software
++# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
++
++
++SEVENZ=`which 7za`
++
++
++mc7zfs_list ()
++{
++ $SEVENZ l "$1" 2> /dev/null | gawk -v uid=${UID-0} '
++BEGIN { flag=0 }
++ /^-------/ { flag++; if (flag > 1) exit 0; next }
++{
++if (flag == 0) next
++
++year=substr($1, 1, 4)
++month=substr($1, 6, 2)
++day=substr($1, 9, 2)
++date=month "-" day "-" year
++
++time=substr($2, 1, 5)
++
++if (index($3, "D") != 0)
++ attr="drwxr-xr-x"
++else
++if (index($3, ".") != 0)
++ attr="-rw-r--r--"
++
++size=$4
++
++$0=substr($0, 54)
++if (NF > 1)
++ name=$0
++else
++ name=$1
++
++gsub(/\\/, "/", name)
++
++printf "%s 1 %-8d %-8d %8d %s %s %s\n", attr, uid, 0, size, date, time, name
++}'
++}
++
++mc7zfs_copyin ()
++{
++# preserve pwd.
++ pwd=`pwd`
++# Create a directory and copy in it the tmp file with the random name
++ dir="$3".dir
++ mkdir "$dir"
++ cd "$dir"
++ mv "$1" .
++ arname=`basename "$1"`
++ di="${2%/*}"
++# if file is to be written upper in the archive tree, make fake dir
++ if test "$di" != "${2##*/}" ; then
++# echo asdsad 1>&2
++ mkdir -p "$di"
++ fi
++# pwd > /tmp/cdir
++# echo "$arname $2" > /tmp/ters
++ cp -fp "$3" "$dir/$2"
++# cp -f "$1" "$3.dir"
++ $SEVENZ a "$arname" "$2" -w >/dev/null 2> /dev/null
++ mv "$arname" "$1"
++ cd $pwd
++ rm -rf "$3.dir"
++}
++
++mc7zfs_copyout ()
++{
++ dir=tmpdir.${RANDOM}
++ mkdir /tmp/"$dir"
++# echo "$1 $2 $3" > hers
++# p7zip 0.91 don't understand filename in subdir without "./"
++# but in top dir it understand only without "./"
++ FLIST=`$SEVENZ l "$1" 2> /dev/null`
++ echo "$FLIST" | grep "[.][/]" > /dev/null 2>&1 && echo "$2" | grep "\/" > /dev/null 2>&1 && EXFNAME=*./"$2" || EXFNAME="$2"
++ EXFN=`basename "$2"`
++ $SEVENZ e -r- "$1" "$EXFNAME" -o/tmp/"$dir" > /dev/null 2> /dev/null
++
++ cat /tmp/"$dir"/"$EXFN" > "$3"
++ rm -rf /tmp/"$dir"
++}
++
++mc7zfs_mkdir ()
++{
++# Function not fully implemented, because 7z cannot keep empty directories
++# preserve pwd.
++ pwd=`pwd`
++# Create a directory and create in it a tmp directory with the good name
++ dir=tmpdir.${RANDOM}
++ mkdir $dir
++ cd $dir
++ mv "$1" .
++ arname=`basename "$1"`
++ mkdir -p "$2"
++# 7z cannot create an empty directory
++# touch "$2"/.emptydir
++ $SEVENZ a -r "$arname" "$2" >/dev/null 2>/dev/null
++# echo "$1" "$2" >error34
++# $SEVENZ d ../"$1" "$2/.7zfs" >/dev/null
++ mv "$arname" "$1"
++ cd $pwd
++ rm -rf $dir
++}
++
++mc7zfs_rm ()
++{
++ $SEVENZ l "$1" 2> /dev/null | grep "[.][\\]" > /dev/null 2>&1 && echo "$2" | grep "\/" > /dev/null 2>&1 && EXFNAME=*./"$2" || EXFNAME="$2"
++ $SEVENZ d "$1" "$EXFNAME" >/dev/null 2> /dev/null
++}
++
++umask 077
++
++cmd="$1"
++shift
++
++case "$cmd" in
++ list) mc7zfs_list "$@" ;;
++ rm) mc7zfs_rm "$@" ;;
++ rmdir) mc7zfs_rm "$@" ;;
++ mkdir) mc7zfs_mkdir "$@" ;;
++ copyin) mc7zfs_copyin "$@" ;;
++ copyout) mc7zfs_copyout "$@" ;;
++ *) exit 1 ;;
++esac
++exit 0
+diff -Naur ../work/mc-4.1.40-pre9/vfs/Makefile.in mc-4.1.40-pre9/vfs/Makefile.in
+--- ../work/mc-4.1.40-pre9/vfs/Makefile.in 2004-08-30 01:20:18.000000000 +0400
++++ mc-4.1.40-pre9/vfs/Makefile.in 2005-04-05 10:10:30.959577512 +0400
+@@ -33,7 +33,7 @@
+ VFSOBJS = $(NONETFILES) @NETFILES@
+
+ EXTFSSTUFF = README extfs.ini a cpio deb ftplist lha lslR \
+- rar rpm zip zoo arfs patchfs mailfs hp48 iso
++ rar rpm zip zoo arfs patchfs mailfs hp48 iso u7z
+
+ #
+ # Distribution variables
+@@ -123,6 +123,7 @@
+ $(INSTALL_PROGRAM) extfs/mailfs $(DESTDIR)$(libdir)/extfs/mailfs
+ $(INSTALL_PROGRAM) extfs/audio $(DESTDIR)$(libdir)/extfs/audio
+ $(INSTALL_PROGRAM) extfs/patchfs $(DESTDIR)$(libdir)/extfs/patchfs
++ $(INSTALL_PROGRAM) extfs/u7z $(DESTDIR)$(libdir)/extfs/u7z
+
+ uninstall:
+ -$(RMF) $(DESTDIR)$(libdir)/extfs/rpm
+@@ -136,6 +137,7 @@
+ -$(RMF) $(DESTDIR)$(libdir)/extfs/iso
+ -$(RMF) $(DESTDIR)$(libdir)/extfs/lslR
+ -$(RMF) $(DESTDIR)$(libdir)/extfs/ftplist
++ -$(RMF) $(DESTDIR)$(libdir)/extfs/u7z
+ -$(RMF) $(DESTDIR)$(libdir)/extfs/extfs.ini
+ -$(RMF) $(DESTDIR)$(libdir)/extfs/README
+ -rmdir $(DESTDIR)$(libdir)/extfs
+
diff --git a/app-misc/mc-mp/files/chdir.gentoo b/app-misc/mc-mp/files/chdir.gentoo
new file mode 100644
index 000000000..9332ba0ee
--- /dev/null
+++ b/app-misc/mc-mp/files/chdir.gentoo
@@ -0,0 +1,11 @@
+
+MC ()
+{
+ mkdir -p $HOME/.mc/tmp 2> /dev/null
+ chmod 700 $HOME/.mc/tmp
+ MC=$HOME/.mc/tmp/mc-$$
+ /usr/bin/mc -P "$MC"
+ cd "`cat $MC`"
+ rm -f "$MC"
+ unset MC;
+}
diff --git a/app-misc/mc-mp/files/digest-mc-mp-4.1.40_pre9 b/app-misc/mc-mp/files/digest-mc-mp-4.1.40_pre9
new file mode 100644
index 000000000..47ef263dc
--- /dev/null
+++ b/app-misc/mc-mp/files/digest-mc-mp-4.1.40_pre9
@@ -0,0 +1,3 @@
+MD5 9335f2b131ecf352c2c0e55a477a1c49 mc-4.1.40-pre9.tar.bz2 991346
+RMD160 83a46ad300cf8ce950b62eb1bfef455e90a90709 mc-4.1.40-pre9.tar.bz2 991346
+SHA256 a191e9ca93767af876fa2dade7c77db86bef42c304d2f3a10216d4be98b5805a mc-4.1.40-pre9.tar.bz2 991346
diff --git a/app-misc/mc-mp/files/ebuild.syntax b/app-misc/mc-mp/files/ebuild.syntax
new file mode 100644
index 000000000..459cdc3e0
--- /dev/null
+++ b/app-misc/mc-mp/files/ebuild.syntax
@@ -0,0 +1,87 @@
+context default
+ keyword linestart HOMEPAGE brightcyan
+ keyword linestart DESCRIPTION brightcyan
+ keyword linestart SRC_URI brightcyan
+ keyword linestart LICENSE brightcyan
+ keyword linestart SLOT brightcyan
+ keyword linestart KEYWORDS brightcyan
+ keyword linestart IUSE brightcyan
+ keyword linestart RESTRICT brightcyan
+ keyword linestart DEPEND brightcyan
+ keyword linestart RDEPEND brightcyan
+ keyword linestart PROVIDE brightcyan
+ keyword linestart S brightcyan
+
+ keyword whole local yellow
+ keyword whole use yellow
+ keyword whole has_version yellow
+ keyword whole best_version yellow
+ keyword whole use_with yellow
+ keyword whole use_enable yellow
+ keyword whole check_KV yellow
+ keyword whole keepdir yellow
+ keyword whole econf yellow
+ keyword whole einstall yellow
+ keyword whole die yellow
+ keyword whole einfo yellow
+ keyword whole emake yellow
+ keyword whole eerror yellow
+ keyword whole epatch yellow
+ keyword whole ebegin yellow
+ keyword whole eend yellow
+ keyword whole ewarn yellow
+ keyword whole unpack yellow
+
+ keyword whole diropts yellow
+ keyword whole dobin yellow
+ keyword whole docinto yellow
+ keyword whole dodir yellow
+ keyword whole dodoc yellow
+ keyword whole doexe yellow
+ keyword whole dohard yellow
+ keyword whole dohtml yellow
+ keyword whole doinfo yellow
+ keyword whole doins yellow
+ keyword whole dolib.a yellow
+ keyword whole dolib.so yellow
+ keyword whole dolib yellow
+ keyword whole doman yellow
+ keyword whole dosbin yellow
+ keyword whole dosym yellow
+ keyword whole exeinto yellow
+ keyword whole exeopts yellow
+ keyword whole fowners yellow
+ keyword whole fperms yellow
+ keyword whole insinto yellow
+ keyword whole insopts yellow
+ keyword whole into yellow
+ keyword whole libopts yellow
+ keyword whole newbin yellow
+ keyword whole newdoc yellow
+ keyword whole newexe yellow
+ keyword whole newins yellow
+ keyword whole newman yellow
+ keyword whole newsbin yellow
+ keyword whole prepall yellow
+ keyword whole prepalldocs yellow
+ keyword whole prepallinfo yellow
+ keyword whole prepallman yellow
+
+ keyword = yellow
+ keyword : yellow
+ keyword ${+} brightgreen
+
+ keyword linestart abcdefghijklmnopqrstuvwxyz_\(\) brightmagenta
+
+ keyword *() brightcyan
+
+ keyword { magenta
+ keyword } magenta
+
+context linestart inherit \n magenta
+ keyword whole inherit yellow
+
+context # \n red
+
+context " " green
+ keyword wholeright ${+} brightgreen
diff --git a/app-misc/mc-mp/files/mc.gentoo b/app-misc/mc-mp/files/mc.gentoo
new file mode 100644
index 000000000..e06f19a89
--- /dev/null
+++ b/app-misc/mc-mp/files/mc.gentoo
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# A little fix so mc exits into it's current working directory
+MC_ENV=/usr/lib/mc/bin/mc.sh
+
+for i in $MC_ENV; do
+ if [ -x $i ]; then
+ . $i
+ fi
+done
+
+# include this, so also xterm,kterm,gterm,etc will have default bash settings
+
+#if [ "x$SHLVL" != "x1" ]; then # We're not a login shell
+# . /etc/profile
+#fi
diff --git a/app-misc/mc-mp/files/mc.ini b/app-misc/mc-mp/files/mc.ini
new file mode 100644
index 000000000..890658ecd
--- /dev/null
+++ b/app-misc/mc-mp/files/mc.ini
@@ -0,0 +1,2 @@
+[Midnight-Commander]
+use_8th_bit_as_meta=0
diff --git a/app-misc/mc-mp/files/mcserv.pamd b/app-misc/mc-mp/files/mcserv.pamd
new file mode 100644
index 000000000..9a144361b
--- /dev/null
+++ b/app-misc/mc-mp/files/mcserv.pamd
@@ -0,0 +1,7 @@
+#%PAM-1.0
+
+auth required pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed
+auth required pam_stack.so service=system-auth
+auth required pam_shells.so
+account required pam_stack.so service=system-auth
+session required pam_stack.so service=system-auth
diff --git a/app-misc/mc-mp/files/mcserv.rc b/app-misc/mc-mp/files/mcserv.rc
new file mode 100644
index 000000000..b185b30ff
--- /dev/null
+++ b/app-misc/mc-mp/files/mcserv.rc
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+###
+# description: The Midnight Commander server allows users on remote machines \
+# to use the Midnight Commander file manager to manipulate their \
+# files on the machine running the server. The server \
+# authenticates the user through PAM, which by default requires \
+# a username/password combination before allowing access.
+
+service_name="mcserv"
+service="/usr/bin/mcserv"
+
+depend() {
+ need net portmap
+}
+
+start() {
+ ebegin "Starting ${service_name}"
+ start-stop-daemon --start --quiet --exec ${service} -- -d
+ result=$?
+ eend $result
+}
+
+stop() {
+ ebegin "Stopping ${service_name}"
+ start-stop-daemon --stop --quiet --exec ${service}
+ result=$?
+ eend $result
+}