summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/youtranslate/youtranslate-1.1.7.2.ebuild')
-rw-r--r--app-misc/youtranslate/youtranslate-1.1.7.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/youtranslate/youtranslate-1.1.7.2.ebuild b/app-misc/youtranslate/youtranslate-1.1.7.2.ebuild
new file mode 100644
index 000000000..67df16642
--- /dev/null
+++ b/app-misc/youtranslate/youtranslate-1.1.7.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit mono eutils
+
+DESCRIPTION="Gtk# frontend for Internet translation services"
+HOMEPAGE="http://laas.altervista.org/youtranslate/ytindex.php"
+SRC_URI="http://laas.altervista.org/youtranslate/${P}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.0
+ >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4"
+
+src_compile() {
+ emake -f Makefile.solution.youtranslate || die "emake failed"
+}
+
+src_install() {
+ dobin youtranslate.exe "${FILESDIR}/youtranslate"
+ doicon yTicon.png
+ make_desktop_entry "${PN}" "YouTranslate!" "yTicon" "Utility"
+}