summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/qbrew/ChangeLog6
-rw-r--r--app-misc/qbrew/Manifest4
-rw-r--r--app-misc/qbrew/qbrew-0.4.1.ebuild33
3 files changed, 41 insertions, 2 deletions
diff --git a/app-misc/qbrew/ChangeLog b/app-misc/qbrew/ChangeLog
index 33ed33ea6..46b28a7d2 100644
--- a/app-misc/qbrew/ChangeLog
+++ b/app-misc/qbrew/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-misc/qbrew
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 17 Jun 2008; Chad A Simmons (CCIEChad) <chad.simmons@member.fsf.org>
+ +qbrew-0.4.1.ebuild:
+ Revision bump for bug 33679 thanks to gentoofan23 for the review
+
04 Dec 2007; Jakub Moc <jakub@gentoo.org> qbrew-0.3.9.ebuild:
Switch to EAPI-1 and slotted deps
diff --git a/app-misc/qbrew/Manifest b/app-misc/qbrew/Manifest
index 85b53bcc6..74a139916 100644
--- a/app-misc/qbrew/Manifest
+++ b/app-misc/qbrew/Manifest
@@ -1,4 +1,6 @@
DIST qbrew-0.3.9.tar.gz 243934 RMD160 cbf6a3a2362aa1b666d329e8dba61081b145fc81 SHA1 d2b290584c25caad2c9dd40733afe9eb937e5274 SHA256 2141f8a62a50dc93e2b8d394d11550d5b4aeaed376de98b323f860f29277342f
+DIST qbrew-0.4.1.tar.gz 291237 RMD160 47a87ae2600e16290526d0eaddf401e8edade285 SHA1 44c82fee8ec93f8c274c87b1b673cd0c44503dea SHA256 045747a8d3454caad416d2f1a26b8cce3c9c9984c62b928fa7366b3090576995
EBUILD qbrew-0.3.9.ebuild 700 RMD160 77a5eb84b30590b9f4e0f590927618081bfb007b SHA1 9382b50a379bfb8085b2cf017287e0d44519963c SHA256 f11aa278a2e657a4adf29e56bcf00f287b75763a907257f2f9dc168227b06485
-MISC ChangeLog 640 RMD160 cfa830bc3fcdc2a6e4eb83494f85f9dfb05dc80c SHA1 9f3e9d0e8cdbe7f03f050c1d542665a63febfbd1 SHA256 e2b0dae53b01627fc6274c7fd760bf3fe9ff719645d17baea805afb9ae746d94
+EBUILD qbrew-0.4.1.ebuild 929 RMD160 7a20702b5bae1013bb0032eda90da6e2cfb2676a SHA1 3be20d932294dc755744ce9a8418346244f5bdb2 SHA256 7ef5aada996004a3e1957b005f516371936302a97b209ddc47f7666e397869ef
+MISC ChangeLog 802 RMD160 f1d856f1b80cb1f7d14007993e7132c40ef7d7b4 SHA1 028437f94b7e20be0fa63ca2f9435ad24382c210 SHA256 25adeaf648e236b977ce94b79264b04da6f0ecbc3708fb8623fa9608a4ea449b
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-misc/qbrew/qbrew-0.4.1.ebuild b/app-misc/qbrew/qbrew-0.4.1.ebuild
new file mode 100644
index 000000000..9af4df6a8
--- /dev/null
+++ b/app-misc/qbrew/qbrew-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit qt4 multilib
+
+DESCRIPTION="Homebrewer's recipe calculator"
+HOMEPAGE="http://www.usermode.org/code.html"
+SRC_URI="http://www.usermode.org/code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4.3)"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export BINDIR="/usr/bin" DATADIR="/usr/share/${PN}" DOCDIR="/usr/share/doc/${P}"
+ ./configure --qtdir="/usr/$(get_libdir)/qt4" || die "configure failed"
+ echo "QT += xml" >> qbrew.pro
+ eqmake4 || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin qbrew || die "bin install failed"
+ insinto /usr/share/${PN}
+ doins data/* pics/splash.png || die "install failed"
+ dohtml -r docs/* || die "documentation install failed"
+ dodoc AUTHORS ChangeLog README TODO || die "documentation install failed"
+}