summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-0.5-r1.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-0.5-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-0.5-r1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-0.5-r1.ebuild
new file mode 100644
index 000000000..38e515b49
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-0.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+PYTHON_DEPEND=*
+inherit python
+
+DESCRIPTION="Update live packages and emerge the modified ones"
+HOMEPAGE="http://qwpx.net/~mgorny/smart-live-rebuild/"
+SRC_URI="http://qwpx.net/~mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ newbin ${PN}.py ${PN} || die
+ dodoc README sets.conf.example || die
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,} || die
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf || die
+}
+
+pkg_postinst() {
+ elog "You might also consider installing [dev-python/psutil] then, which is required"
+ elog "for ${PN} automatically detect if it was spawned by emerge."
+}