summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/clewn/clewn-9999.ebuild')
-rw-r--r--app-vim/clewn/clewn-9999.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/app-vim/clewn/clewn-9999.ebuild b/app-vim/clewn/clewn-9999.ebuild
index 8de0ec6b5..5a1166f84 100644
--- a/app-vim/clewn/clewn-9999.ebuild
+++ b/app-vim/clewn/clewn-9999.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit eutils subversion vim-doc
DESCRIPTION="A small utility which allows debugging from within vim"
@@ -13,22 +15,13 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="debug"
-DEPEND=">=app-editors/gvim-7.0
+DEPEND=">=app-editors/gvim-7.0[netbeans]
sys-libs/readline"
RDEPEND="${DEPEND}
sys-devel/gdb"
-pkg_setup() {
- if ! built_with_use app-editors/gvim netbeans ; then
- eerror "Please (re)emerge gvim with netbeans USE flag on before "
- eerror "emerging clewn"
- die "please (re)emerge app-editors/gvim with USE='netbeans'"
- fi
-}
-
-src_compile() {
+src_configure() {
vimdir=/usr/share/vim/vimfiles econf $(use_enable debug)
- emake || die "emake failed"
}
src_install() {