summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sphinx/sphinx-0.9.7_rc2.ebuild')
-rw-r--r--dev-db/sphinx/sphinx-0.9.7_rc2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/sphinx/sphinx-0.9.7_rc2.ebuild b/dev-db/sphinx/sphinx-0.9.7_rc2.ebuild
new file mode 100644
index 000000000..bbbddcd42
--- /dev/null
+++ b/dev-db/sphinx/sphinx-0.9.7_rc2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/-rc}"
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mysql postgres debug"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fix-sandbox.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with mysql) \
+ $(use_with postgres) \
+ $(use_with debug)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/* example.sql
+ insinto /etc/
+ doins sphinx.conf.dist
+}