summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sql2class/sql2class-1.9.1.ebuild')
-rw-r--r--dev-db/sql2class/sql2class-1.9.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-db/sql2class/sql2class-1.9.1.ebuild b/dev-db/sql2class/sql2class-1.9.1.ebuild
deleted file mode 100644
index 136df1b8f..000000000
--- a/dev-db/sql2class/sql2class-1.9.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs
-
-KEYWORDS="~x86"
-
-DESCRIPTION="SQL C++ code generator (to use with dev-db/*wrapped packages)"
-HOMEPAGE="http://www.alhem.net/project/sql2class/index.html"
-SRC_URI="http://www.alhem.net/project/sql2class/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="mysql sqlite"
-
-DEPEND=""
-RDEPEND="mysql? ( dev-db/mysqlwrapped )
- sqlite? ( dev-db/sqlitewrapped )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-extra_qualifiers.patch"
-
- sed -i \
- -e 's/\(CPPFLAGS\) =/\1+=/' \
- -e 's/-Wall -O2 -g//' \
- -e 's#/usr/devel#/usr#' \
- Makefile || die "sed failed"
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" || die "emake failed"
-}
-
-src_install() {
- dobin sql2class
- dodoc README
-}
-
-pkg_postinst() {
- elog "You might want to emerge one of the following packages as well:"
- elog "-> dev-db/mysqlwrapped ... to use the generated code with a MySQL-DB"
- elog "-> dev-db/sqlitewrapped ... to use the generated code with SQLite"
-}