summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqliteman/sqliteman-0.99_pre20070421.ebuild')
-rw-r--r--dev-db/sqliteman/sqliteman-0.99_pre20070421.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-db/sqliteman/sqliteman-0.99_pre20070421.ebuild b/dev-db/sqliteman/sqliteman-0.99_pre20070421.ebuild
deleted file mode 100644
index dcb133566..000000000
--- a/dev-db/sqliteman/sqliteman-0.99_pre20070421.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-DESCRIPTION="simple but powerfull Sqlite3 GUI database manager"
-HOMEPAGE="http://sqliteman.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sqliteman/${P/_pre/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND=">=x11-libs/qt-4.2
- >=dev-db/sqlite-3.0"
-DEPEND="${RDEPEND}
- dev-util/cmake"
-
-MY_P="sqliteman-0.99"
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- if ! built_with_use x11-libs/qt sqlite3; then
- eerror "sqliteman requires that x11-libs/qt will be"
- eerror "compiled with sqlite3 support"
- die "Please, rebuild x11-libs/qt with the \"sqlite3\" USE flag."
- fi
- cmake . \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
- -DCMAKE_C_FLAGS="${CFLAGS}" \
- || die "cmake failed"
- emake || die "Compile Failed!"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install Failed!"
-
- dodoc AUTHORS README
-
-}